Bug 120769 - update of kernel fails because mkinitrd cannot get loopback device
update of kernel fails because mkinitrd cannot get loopback device
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: policy (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-13 16:05 EDT by Gene Czarcinski
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-14 11:38:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2004-04-13 16:05:22 EDT
Description of problem:

I thought this had been reported but I cannot find the report now.

policy = 1.11.1-2

selinux=1, enforcing=1

When I run up2date (or even just manually install), I get:

up2date
http://fedora.redhat.com/download/up2date-mirrors/fedora-core-rawhide
using mirror:
http://mirror.hiwaay.net/redhat/fedora/linux/core/development/x86_64/
/usr/share/rhn/up2date_client/checklist.py:139: DeprecationWarning:
integer argument expected, got float
  info  = self.get_selection_info (event.x, event.y)
WARNING: /lib/modules/2.6.5-1.319/unsupported/fs/reiserfs/reiserfs.ko
needs unknown symbol sleep_on
/bin/bash: /root/.bashrc: Permission denied
All of your loopback devices are in use.
mkinitrd failed


And in /var/log/messages is:

Apr 13 16:03:07 hummer kernel: audit(1081886587.799:0): avc:  denied 
{ read } for  pid=15581 exe=/sbin/nash name=loop0 dev=hda10 ino=806783
scontext=root:sysadm_r:bootloader_t
tcontext=system_u:object_r:device_t tclass=blk_file
Comment 1 Daniel Walsh 2004-04-13 16:55:12 EDT
The problem is that the /dev/loop0 has the wrong context on it, it
should be fixed_disk_device_t but it looks like it is device_t?

This might be caused by udev.

Dan
Comment 2 Gene Czarcinski 2004-04-14 11:38:16 EDT
udev update applied (plus policy and polic-source).  I can now install
a kernel with enforcing=1 ... closing

Note You need to log in before you can comment on or make changes to this bug.