This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 120773 - can't delete SPDs
can't delete SPDs
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
:
: 123747 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-13 16:26 EDT by Bill Nottingham
Modified: 2014-03-16 22:44 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-21 17:00:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2004-04-13 16:26:27 EDT
kernel-2.6.5-1.315, ipsec-tools-0.2.5-1

Given:

172.16.56.99[any] 172.16.56.74[any] any
        out ipsec
        esp/transport//require
        ah/transport//require
        created: Apr 13 12:10:43 2004  lastused: Apr 13 16:00:10 2004
        lifetime: 0(s) validtime: 0(s)
        spid=17 seq=6 pid=14613
        refcnt=2

Attempting to remove it yields:
[root@nostromo sbin]# setkey  -c
spddelete 172.16.56.99 172.16.56.74 any -P out;
The result of line 1: No entry.

It can be removed with 'setkey -P -F'.

This works with the same ipsec-tools code on a RHEL3 kernel.
Comment 1 Bill Nottingham 2004-05-25 12:14:37 EDT
*** Bug 123747 has been marked as a duplicate of this bug. ***
Comment 2 Christopher Johnson 2004-07-12 19:12:42 EDT
In my testing this appears to be solved with kernel-2.6.6-1.435.2.3
and ipsec-tools-0.2.5-4.

Note You need to log in before you can comment on or make changes to this bug.