This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 120782 - (ALSA VIA)vt8233 sound does not work in FC2T2
(ALSA VIA)vt8233 sound does not work in FC2T2
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-13 17:08 EDT by Gene Czarcinski
Modified: 2015-01-04 17:05 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-08 08:29:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2004-04-13 17:08:17 EDT
Description of problem:

This works OK in FC1 x86_64 so the hardware/speakers are basically OK.

I have a VIA VT8233/A/8235/8237 AC97 Audio Controller (rev 60) in an
ASUS SK8V with an Opteron 140

The VT8233 is recognized by system-config-soundcard but I cannot
increase the volume.  It does not see any problem before or after I do
the "modprobe snd-via82xx"

If I try running gnome-volume-control I get a popup saying "Sorry, no
mixer elements and/or devices found".  

x86_64 kernel = 2.6.5-1.319

I am not running kudzu because it has problems with the NIC (sk98lin).

/etc/modprobe.conf:

alias eth0 sk98lin
alias scsi_hostadapter sata_via
alias sound-slot-0 snd-via82xx
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx &&
/usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-via82xx { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-via82xx
alias usb-controller ehci-hcd
alias usb-controller1 uhci-hcd
alias ieee1394-controller ohci1394

When I first boot up the drive is not loaded but then it is after I do
  modprobe snd-via82xx

lsmod (after the modprobe):

Module                  Size  Used by
snd_via82xx            29536  0
snd_pcm               112140  1 snd_via82xx
snd_timer              32904  1 snd_pcm
snd_ac97_codec         73732  1 snd_via82xx
snd_page_alloc         11016  2 snd_via82xx,snd_pcm
gameport                4352  1 snd_via82xx
snd_mpu401_uart        10368  1 snd_via82xx
snd_rawmidi            27296  1 snd_mpu401_uart
snd_seq_device          8076  1 snd_rawmidi
snd_mixer_oss          19328  0
snd                    55528  8
snd_via82xx,snd_pcm,snd_timer,snd_ac97_codec,snd_mpu401_uart,snd_rawmidi,snd_seq_device,snd_mixer_oss
soundcore              10528  1 snd
parport_pc             27456  1
lp                     12920  0
parport                48396  2 parport_pc,lp
autofs4                23936  0
rfcomm                 49456  0
l2cap                  29448  5 rfcomm
bluetooth              62404  4 rfcomm,l2cap
ds                     17288  0
yenta_socket           16896  0
pcmcia_core            59792  2 ds,yenta_socket
sunrpc                174048  1
sk98lin               173100  1
ipt_REJECT              6016  1
ipt_state               2048  2
ip_conntrack           32588  1 ipt_state
iptable_filter          2944  1
ip_tables              16896  3 ipt_REJECT,ipt_state,iptable_filter
button                  6184  0
battery                 9104  0
asus_acpi              12064  0
ac                      4752  0
radeon                123488  2
ipv6                  280896  14
ext3                  120432  1
jbd                    86320  1 ext3
sata_via                6020  0
libata                 41856  1 sata_via,[permanent]
sd_mod                 20224  0
scsi_mod              137248  2 libata,sd_mod

lspci:

00:00.0 Host bridge: VIA Technologies, Inc. VT8385 [K8T800 AGP] Host
Bridge (rev 01)
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI bridge [K8T800
South]
00:07.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host
Controller (rev 80)
00:0a.0 Ethernet controller: 3Com Corporation 3c940 1000Base? (rev 12)
00:0f.0 RAID bus controller: VIA Technologies, Inc.: Unknown device
3149 (rev 80)
00:0f.1 IDE interface: VIA Technologies, Inc.
VT82C586A/B/VT82C686/A/B/VT823x/A/C/VT8235 PIPC Bus Master IDE (rev 06)
00:10.0 USB Controller: VIA Technologies, Inc. VT6202 [USB 2.0
controller] (rev 81)
00:10.1 USB Controller: VIA Technologies, Inc. VT6202 [USB 2.0
controller] (rev 81)
00:10.2 USB Controller: VIA Technologies, Inc. VT6202 [USB 2.0
controller] (rev 81)
00:10.3 USB Controller: VIA Technologies, Inc. VT6202 [USB 2.0
controller] (rev 81)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8237 ISA bridge [K8T800
South]
00:11.5 Multimedia audio controller: VIA Technologies, Inc.
VT8233/A/8235/8237 AC97 Audio Controller (rev 60)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 NorthBridge
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 NorthBridge
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 NorthBridge
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 NorthBridge
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon R200 QM
[Radeon 9100] (rev 80)
Comment 1 Gene Czarcinski 2004-04-14 08:50:16 EDT
There are problems between selinux policy and udev which get some
things set wrong and cause audio not to work.  For purposes of this
test, I am booting with enforcing=0.

I also search lkml and did not find much there.  There was one thread
which claimed sound had not worked since 2.6.2 but that looked like it
related to other problems on the Sony Laptop.  Besides, that did not
have irq5 assigned to the VT8233 and my box does.
Comment 2 Karen Spearel 2004-04-14 10:51:30 EDT
snd_via82xx is working fine here on my K8V (it actually came up with
the the volume control working much to my surprise). My modprobe.conf
is identical as far as the sound stuff is concerned but the very first
thing listed with lsmod is snd_mixer_oss here...don't see that listed
above...other sound related things are similar although use counts are
different.  This is on a clean FC2 T2 install with selinux disabled
during the install.  I do see a kernel oops when running kudzu when
booting up but it doesn't show in the logs and doesn't seem to be
affecting anything...boot continues and everything seems to work fine.
 I do haver sklin98 commented out in modprobe.conf due to a previous
modprobe issue and haven't switched back lately to see if that problem
has been fixed.  I also comment out the sata_via and ohci1394 modules
that I don't use.  lspci here reports the same things.
Comment 3 Gene Czarcinski 2004-04-14 13:09:50 EDT
This is a ASUS SK8V with an Opteron 140.  I am not sure what the
differences are but there must be some since mine does not work.

It does work fine with FC1 x86_64.  It does not work with either
FC2-T2+development i386 or FC2-T2+development x86_64.

Everything seems to "go through the motions" but no sound comes out.

Comment 4 Gene Czarcinski 2004-04-14 13:13:21 EDT
After applying udev-023-2, policy/policy-sources 1.11.2-1, and
kernel-2.6.5-1.322, I can boot with enforcing=1 and the modules load.
 Other than that, no change.

lsmod:
Module                  Size  Used by
snd_mixer_oss          19328  2
snd_via82xx            29536  3
snd_pcm               112140  1 snd_via82xx
snd_timer              32904  1 snd_pcm
snd_ac97_codec         73732  1 snd_via82xx
snd_page_alloc         11016  2 snd_via82xx,snd_pcm
gameport                4352  1 snd_via82xx
snd_mpu401_uart        10368  1 snd_via82xx
snd_rawmidi            27296  1 snd_mpu401_uart
snd_seq_device          8076  1 snd_rawmidi
snd                    55528  10
snd_mixer_oss,snd_via82xx,snd_pcm,snd_timer,snd_ac97_codec,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore              10528  3 snd
parport_pc             27456  1
lp                     12920  0
parport                48396  2 parport_pc,lp
autofs4                23936  0
rfcomm                 49456  0
l2cap                  29448  5 rfcomm
bluetooth              62404  4 rfcomm,l2cap
ds                     17288  0
yenta_socket           16896  0
pcmcia_core            59792  2 ds,yenta_socket
sunrpc                174048  1
sk98lin               173100  1 [unsafe]
ipt_REJECT              6016  1
ipt_state               2048  2
ip_conntrack           32588  1 ipt_state
iptable_filter          2944  1
ip_tables              16896  3 ipt_REJECT,ipt_state,iptable_filter
button                  6184  0
battery                 9104  0
asus_acpi              12064  0
ac                      4752  0
radeon                123488  2
ipv6                  280896  14
ext3                  120432  1
jbd                    85424  1 ext3
sata_via                6020  0
libata                 41856  1 sata_via,[permanent]
sd_mod                 20224  0
scsi_mod              137248  2 libata,sd_mod


cat /proc/interrupts
           CPU0
  0:    1297356          XT-PIC  timer
  1:         54          XT-PIC  i8042
  2:          0          XT-PIC  cascade
  5:          0          XT-PIC  VIA8233
  8:          0          XT-PIC  rtc
  9:          0          XT-PIC  acpi
 10:       2528          XT-PIC  ide2, SysKonnect SK-98xx
 11:      76800          XT-PIC  radeon@PCI:1:0:0
 12:       1988          XT-PIC  i8042
 14:      23954          XT-PIC  ide0
 15:         22          XT-PIC  ide1
NMI:         95
LOC:    1296862
ERR:         16
MIS:          0
Comment 5 Karen Spearel 2004-04-14 14:49:33 EDT
sorry...I misstated when is said FC2T2...this is really a clean
install of FC2T2 + devel updates current as of this morning (latest
selinux libs excluded but unused anyhow).  322 removed the kernel oops
mentioned in my earlier comment.

Comparing lsmod output directly above with mine, all the sound entries
are identical including the use counts when sound isn't in use. 
/proc/interrupts look the similar except that ehci_hcd is listed along
with VIA8233 on int5 and uhci_hcd shows up twice each on int10 and
int11.  Odd that usb controllers don't show up in the above
/proc/interrupts listing.  When an .ogg file is playing on rhythmbox,
use counts for snd_via82xx and snd_pcm are each incremented by
1...other entries remain the same.

I haven't installed either the i386 nor the x86_64 with selinux
enabled here on this box...I will install x86_64 with selinux enabled
later today when I can get things moved around so the selinux enabled
partition doesn't see the disabled one.  Report to follow. 
Comment 6 Karen Spearel 2004-04-15 08:40:53 EDT
Sound does *not* work on a clean install of FC2T2 x86_64 with selinux
enabled on my K8V/3200+.  The sound test in firstboot is silent.  When
adjusting the volume control to increase volume, it resets itself to
zero.  Note that sound does work on this system when installed with
selinux disabled and updated to devel.  Initial testing was with no
updates. Will report further when updated to current devel.
Comment 7 Karen Spearel 2004-04-15 17:00:48 EDT
FWIW, sound is working on my K8V FC2T2+development x86_64 in both
permissive and enforcing modes.  
Comment 8 Gene Czarcinski 2004-04-15 17:18:28 EDT
Yes, I know.  However, apparently the ASUS K8V (socket754) is not
quite the same as an ASUS SK8V (socket940).  My problem is with the
SK8V and I have at least one confirmation that it does not work on
another persons system either.
Comment 9 Karen Spearel 2004-04-15 18:19:42 EDT
Understood...I reported for completeness.  Since the K8V doesn't have
the problem with or without selinux, my input was spurious.
Comment 10 Gene Czarcinski 2004-04-16 15:46:39 EDT
OK, I have pretty much given up on this although I will leave this
open.  If someone wants me to try something, I will try and make the time.

SOmetimes it is better to switch than fight and I am tired of fighting
this ... I disabled on onboard VIA8233 and plugged in a Ensoniq 5880
AudioPCI adapter suppoerted by the snd-ens1371 driver.  While I had
some problems getting it to work (which will go into another bugzilla
report), it nore works and I have sound.
Comment 11 john 2004-07-21 09:23:05 EDT
Howdy.  No help here but for your sanity I have the sk8v and opteron 
146 and the sound panel in the back is not working also.

Weird:  Everything installs and it even recognizes when I plug in 
speakers, but no sound is coming out. 

I did connect the front panel internal audio connectors and these 
seem to work fine...
Comment 12 Dave Jones 2004-12-08 01:03:23 EST
is this still a problem with the current updates / trees ?
Comment 13 Gene Czarcinski 2004-12-08 08:29:38 EST
OBE from my perspective so I am closing it.  In all likelyhood it is a
MOBO problem rather than software.  I changed hardware and it would
not be practical to test with FC3.

Note You need to log in before you can comment on or make changes to this bug.