Bug 120804 - (ALSA AUDIGY) No sound available with a soundblaster audigy gamer
(ALSA AUDIGY) No sound available with a soundblaster audigy gamer
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-13 20:53 EDT by Th0ma7
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-09 20:08:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My ALSA Mixer settings (34.58 KB, image/png)
2004-06-02 21:01 EDT, Th0ma7
no flags Details

  None (edit)
Description Th0ma7 2004-04-13 20:53:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
On Core 2 the sound has never worked yet... It was working properly on
core 1.

Here is my system specs:
ASUS CUV4X-D (dual 1ghz system)
Adaptec 29160 scsi
sndblaster audigy gamer

Tried kernel 2.6.3.x to 2.6.5-319smp

The sound system looks like working (lsmod):
Module                  Size  Used by
snd_seq_oss            31232  0
snd_seq_midi            9760  0
snd_emu10k1_synth       9728  0
snd_emux_synth         34816  1 snd_emu10k1_synth
snd_seq_virmidi         9216  1 snd_emux_synth
snd_seq_midi_event     10240  3 snd_seq_oss,snd_seq_midi,snd_seq_virmidi
snd_seq_midi_emul      10112  1 snd_emux_synth
snd_seq                50960  8
snd_seq_oss,snd_seq_midi,snd_emux_synth,snd_seq_virmidi,snd_seq_midi_event,snd_seq_midi_emul
snd_pcm_oss            45604  0
snd_mixer_oss          17792  2 snd_pcm_oss
snd_emu10k1            82436  4 snd_emu10k1_synth
snd_rawmidi            23072  3 snd_seq_midi,snd_seq_virmidi,snd_emu10k1
snd_pcm                81028  3 snd_pcm_oss,snd_emu10k1
snd_timer              24708  2 snd_seq,snd_pcm
snd_seq_device         10120  7
snd_seq_oss,snd_seq_midi,snd_emu10k1_synth,snd_emux_synth,snd_seq,snd_emu10k1,snd_rawmidi
snd_ac97_codec         56196  1 snd_emu10k1
snd_page_alloc         12036  2 snd_emu10k1,snd_pcm
snd_util_mem            7168  2 snd_emux_synth,snd_emu10k1
snd_hwdep              10372  2 snd_emux_synth,snd_emu10k1
snd                    45540  19
snd_seq_oss,snd_seq_midi,snd_emux_synth,snd_seq_virmidi,snd_seq_midi_event,snd_seq,snd_pcm_oss,snd_mixer_oss,snd_emu10k1,snd_rawmidi,snd_pcm,snd_timer,snd_seq_device,snd_ac97_codec,snd_util_mem,snd_hwdep
soundcore              10720  2 snd


I've tried to put my system on "PnP OS" and without "PnP OS" and on
both cases I've deleted the configuration associated with my soundcard
in my /etc/sysconfig/hwconf

I know that there was an issue in a old kernel 2.4.x with mps 1.4
support but this probably has nothing to do with this.. and it was
fixed a long time ago.

It always redetected my soundcard properly.

In soundcard detection there is a Creative Labs SB Audigy using
snd-emu10k1 module... But Play test sound option produces nothing.

In KDE I've tried to play a bit with the sound system and testing the
sound and actually seing an output in the Arts Control Tool but still
can't hear anything.

I've also tried to activate the Sound Mixer applet and put everything
up to make sure my volume was properly setup... still nothing.

I've made a quick search in my tmp directory and found out
xses-<USER>.<RANDOM> files... Here is what's in it:
xset:  bad font path element (#88), possible causes are:
    Directory does not exist or has wrong permissions
    Directory missing fonts.dir
    Incorrect font server address or syntax
startkde: Starting up...
QPixmap: Cannot create a QPixmap when no GUI is being used
QPixmap: Cannot create a QPixmap when no GUI is being used
QPixmap: Cannot create a QPixmap when no GUI is being used
QPixmap: Cannot create a QPixmap when no GUI is being used
kbuildsycoca running...
QPixmap: Cannot create a QPixmap when no GUI is being used
QPixmap: Cannot create a QPixmap when no GUI is being used
ALSA lib pcm_hw.c:494:(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed:
Broken pipe
ALSA lib pcm_hw.c:494:(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed:
Broken pipe
ALSA lib pcm_hw.c:494:(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed:
Broken pipe
There are already artsd objects registered, looking if they are active...
ALSA lib pcm_hw.c:494:(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed:
Broken pipe

Error: Can't add object reference (probably artsd is already running).
       If you are sure it is not already running, remove the relevant
files:

       /tmp/mcop-root/Arts_SoundServerV2
       /tmp/mcop-root/Arts_SoundServer
       /tmp/mcop-root/Arts_SimpleSoundServer
       /tmp/mcop-root/Arts_PlayObjectFactory
       /tmp/mcop-root/Arts_AudioManager

QWidget::setMinimumSize: The smallest allowed size is (0,0)
QWidget::setMinimumSize: The smallest allowed size is (0,0)
Klipper is already running!
Gtk-WARNING **: invalid cast from `GtkSuperWin' to `GtkWidget'

Gtk-WARNING **: invalid cast from `GtkSuperWin' to `GtkWidget'

Gtk-WARNING **: invalid cast from `GtkSuperWin' to `GtkWidget'
amixer: Unknown playback setup 'on'..

amixer: Unknown playback setup 'on'..

-8
amixer: Unknown playback setup 'on'..

amixer: Unknown playback setup 'on'..

amixer: Unknown playback setup 'on'..

amixer: Unknown playback setup 'on'..

okay
server status: suspended
real-time status: not started through real-time wrapper
server buffer time: 92.8798 ms
buffer size multiplier: 1
minimum stream buffer time: 92.8798 ms
auto suspend time: 60 s
audio method: alsa
sampling rate: 44100
channels: 2
sample size: 16 bits
duplex: half
device: default
fragments: 4
fragment size: 4096
-8
-8
okay


Version-Release number of selected component (if applicable):
alsa-lib-1.0.3a-1

How reproducible:
Always

Steps to Reproduce:
1. Everytime I open any session has root or has a user.
2.
3.
    

Actual Results:  no sound

Expected Results:  hearing sound

Additional info:
Comment 1 Esben Ostergaard 2004-04-20 16:20:05 EDT
I probably have the same problem, exept that I do get sound from the
frount panel of my SoundBlaster Audigy, but just not from the back
panel. I have turned up the volume on all channels. I also get the lines;
> cat /tmp/xses-*.* | grep "ALSA"
ALSA lib pcm_hw.c:494:(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed:
Broken pipe
ALSA lib pcm_hw.c:494:(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed:
Broken pipe
ALSA lib pcm_hw.c:494:(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed:
Broken pipe

FC2T2, kernel 2.6.5-1.332

Esben
Comment 2 Th0ma7 2004-04-30 21:23:53 EDT
I've installed FC2T3 and.. for the first time my audigy worked at
first glance at first boot (in the config 1st boot gui)... 

Hence, I only installed KDE by default and when I logged in, no more
sound... arts does not complain but can't ear anything.. even the
system-sound-config tool does not play any sound anymore... even with
everything up in the mixer applet.

snip.
Comment 3 Raymond E. Gintner IV 2004-05-30 23:50:28 EDT
    I was able to get my audigy working in run level 3 by running the
alsamixer program, and "muting" the item "Audigy Analog/Digital output
Jack".  I think the driver is defaulting to digital output.
    KDE is still unhappy, though, but my setup is different: I've also
got onboard audio (A7N8X-E deluxe motherboard, using snd-intel8x0
driver) that ALSA says is card 0.  KDE insists on routing audio to
card 0, no matter which card I select in the soundcard detection tool!
 KDE also forced the audigy card (card 1) back to digital output.
    Everything seems to work from command line - both cards work when
addressed, doing what I tell them to.

    Hope this helps somehow.
Comment 4 Th0ma7 2004-06-02 21:01:47 EDT
Created attachment 100813 [details]
My ALSA Mixer settings

Everyting is at 100% except these 5 I cannot set (seems to be locked):
   TONE
   Mic Boost (+20db)
   IEC958 Optical Raw
   Audigy Analog/Digital Output Jack
   External Amplifier
Comment 5 Th0ma7 2004-06-02 21:03:04 EDT
Still ain't working.. I've read a bit on 2.6.7-rc2 kernel and there
seems to be a newer release of alsa (1.0.4) which might fix my problem..
Comment 6 Ivo Sarak 2004-06-03 13:19:08 EDT
The same issue here - no sound.

Portion of lspci:
00:0c.0 Multimedia audio controller: Creative Labs SB Audigy (rev 03)
00:0c.1 Input device controller: Creative Labs SB Audigy MIDI/Game
port (rev 03)

lsmod:
Module                  Size  Used by
snd_mixer_oss          13824  0
floppy                 47440  0
snd_emu10k1            71172  0
snd_rawmidi            17184  1 snd_emu10k1
snd_pcm                68872  1 snd_emu10k1
snd_timer              17156  1 snd_pcm
snd_seq_device          6152  2 snd_emu10k1,snd_rawmidi
snd_ac97_codec         50436  1 snd_emu10k1
snd_page_alloc          7940  2 snd_emu10k1,snd_pcm
snd_util_mem            3200  1 snd_emu10k1
snd_hwdep               6276  1 snd_emu10k1
snd                    38372  9
snd_mixer_oss,snd_emu10k1,snd_rawmidi,snd_pcm,snd_timer,snd_seq_device,snd_ac97_codec,snd_util_mem,snd_hwdep
soundcore               6112  1 snd
r128                   72368  2
ipv6                  184288  12
parport_pc             19392  0
lp                      8236  0
parport                29640  2 parport_pc,lp
3c59x                  30376  0
dm_mod                 33184  0
uhci_hcd               23708  0
button                  4504  0
battery                 6924  0
asus_acpi               8472  0
ac                      3340  0
ext3                  102376  4
jbd                    40216  1 ext3
sata_sil                4996  2
libata                 29312  1 sata_sil,[permanent]
aic7xxx               135864  0
sd_mod                 16384  4
scsi_mod               91344  3 libata,aic7xxx,sd_mod

Mixer setting do not make a difference.
Comment 7 Ivo Sarak 2004-06-03 13:21:00 EDT
If any help then
# uname -a:
Linux sarmax 2.6.5-1.358 #1 Sat May 8 09:04:50 EDT 2004 i686 athlon
i386 GNU/Linux

# cat /etc/redhat-release
Fedora Core release 2 (Tettnang)
Comment 8 Th0ma7 2004-06-07 07:30:53 EDT
I've tried kernel 2.6.6 and 2.6.7-rc2 hoping that the updated alsa
drivers might help.... did'nt worked.  I've also applied the latest
ALSA driver 1.0.5a, libs and tools... still nothing.
Comment 9 Ivo Sarak 2004-06-08 17:04:30 EDT
I was also able to get my audigy working when "muting" the item
"Audigy Analog/Digital output Jack" with alsamixer. 
Comment 10 Ivo Sarak 2004-06-08 17:20:27 EDT
How do save the alsamixer settings so after reboot the "muting" is
still present?
Comment 11 Th0ma7 2004-06-09 20:07:05 EDT
Finally my problem is resolved:
https://bugtrack.alsa-project.org/alsa-bug/bug_view_page.php?bug_id=0000327

You need to make sure that some channels are muted with the "M" option.

Here is the info I got and it worked:
-------------------------
These are switches - you can mute, unmute it using M key in alsamixer.
Make sure that
IEC958 Optical Raw4
Audigy Analog/Digital Output Jack
are muted (in alsamixer there should be MM above bars.

make shure that these volumes are not 0
Master
PCM
Front - kmix seem to have bug and this kontrol not work in it - use
alsamixer

Comment 12 Ivo Sarak 2004-06-10 03:56:12 EDT
How come this is not a bug?

Nice but as soon I enter KDE these channels are unmuted again. It is
not normal to mute these every time someone will reboot the box.

Note You need to log in before you can comment on or make changes to this bug.