Bug 120837 - grub depends on redhat-logos
grub depends on redhat-logos
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: grub (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
: 120842 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-14 09:06 EDT by Niki W. Waibel
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-09 17:39:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Niki W. Waibel 2004-04-14 09:06:43 EDT
Description of problem:
you can do a
        rpm -e redhat-logos
without warning. grub (booting) will not work anymore from
that point on, because it uses
        splashimage=(hd0,0)/boot/grub/splash.xpm.gz
in its config file.

Version-Release number of selected component (if applicable):
na

How reproducible:
rpm -e redhat-logos
reboot

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
either removal of redhat-logos rewrites the grub.conf file not
using a boot logo or grub has to depend on redhat-logos.
Comment 1 Suzanne Hillman 2004-04-14 10:52:54 EDT
*** Bug 120842 has been marked as a duplicate of this bug. ***
Comment 2 Jeremy Katz 2004-06-09 17:39:05 EDT
Added requirement in CVS for the next build of grub.

Note You need to log in before you can comment on or make changes to this bug.