Bug 120868 - new-kernel-pkg fails to install 2.6 vmlinuz-$version.
new-kernel-pkg fails to install 2.6 vmlinuz-$version.
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
Depends On:
  Show dependency treegraph
Reported: 2004-04-14 14:18 EDT by David Woodhouse
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 3.5.21-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-07-07 14:03:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Patch to DTRT for both 2.4 and 2.6 kernels (777 bytes, patch)
2004-04-14 14:19 EDT, David Woodhouse
no flags Details | Diff

  None (edit)
Description David Woodhouse 2004-04-14 14:18:44 EDT
For 2.6 kernels kernelName should be 'vmlinuz' not 'vmlinux'
Comment 1 David Woodhouse 2004-04-14 14:19:28 EDT
Created attachment 99418 [details]
Patch to DTRT for both 2.4 and 2.6 kernels
Comment 2 Jeremy Katz 2004-04-14 23:23:54 EDT
Did something along these lines for 3.5.21 (slightly different kernel
version test)
Comment 3 David Woodhouse 2004-04-15 08:45:24 EDT
Should it depend on ppc64-utils, even on ppc32?
Comment 4 Paul Nasrat 2004-04-15 08:57:31 EDT
There is a ppc-utils package I created that provides pmac-utils and
ppc64-utils.  IIRC the actual require is for one of the pmac-utils
binaries for open firmware:


Comment 5 David Woodhouse 2004-04-15 09:28:01 EDT
Our ppc64-utils rpm contains pmac-utils and hence nvsetenv. But it's
not in the FC2 package list AFAICT.
Comment 6 Matthew Miller 2006-07-07 14:03:56 EDT
yeah, so, presumably there were no problems with the fix for this. marking resolved.

Note You need to log in before you can comment on or make changes to this bug.