Bug 120897 - open ldap does not all me to add or modify entries.
open ldap does not all me to add or modify entries.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openldap (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-14 21:21 EDT by Bill Brown
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-15 03:58:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Brown 2004-04-14 21:21:46 EDT
Description of problem:
After installing FC2 Test 2 everything,  I tried to create an ldap 
directory entry and got the following:
(console)
[root@x1-6-00-d0-68-01-57-18 openldap]# ldapadd -D 
'dc=colorfulsoftware, dc=com' -f directory.ldif -W
Enter LDAP Password:
SASL/GSSAPI authentication started
ldap_sasl_interactive_bind_s: Local error (82)
        additional info: SASL(-1): generic failure: GSSAPI Error: 
Miscellaneous failure (No credentials cache found)
[root@x1-6-00-d0-68-01-57-18 openldap]#


Version-Release number of selected component (if applicable):
[root@x1-6-00-d0-68-01-57-18 openldap]# rpm -qa | grep -i ldap
nss_ldap-212-1
openldap-servers-2.1.25-5.1
openldap-devel-2.1.25-5.1
openldap-2.1.25-5.1
perl-LDAP-0.31-4
openldap-clients-2.1.25-5.1
php-ldap-4.3.4-10.1


How reproducible:
install the latest and try to add an entry. 

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Nalin Dahyabhai 2004-04-15 03:58:18 EDT
Your server supports use of the GSSAPI SASL mechanism for
authentication, but you have no credentials with which to authenticate
using this mechanism (or your client configuration makes this appear
to be the case).

Because you're supplying a password, I think your intention is to use
simple authentication instead of SASL authentication.  Try running
ldapadd with the -x option to force use of simple authentication.

Marking notabug because this is the specified and documented behavior.

Note You need to log in before you can comment on or make changes to this bug.