Bug 120922 - (IT_37146) Mozilla does not start up if LANG is set as non-US locale.
Mozilla does not start up if LANG is set as non-US locale.
Status: CLOSED DUPLICATE of bug 134513
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: mozilla (Show other bugs)
2.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Ben Levenson
:
Depends On:
Blocks: 136201
  Show dependency treegraph
 
Reported: 2004-04-15 07:23 EDT by Keiichi Mori
Modified: 2007-11-30 17:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Keiichi Mori 2004-04-15 07:23:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
Mozilla does not start up if LANG is set as non-US locale.
In case that $HOME/.mozilla directory is not available (first
start-up), mozilla start up sucessfully.


Version-Release number of selected component (if applicable):
mozilla-1.4.2-2.1.0

How reproducible:
Always

Steps to Reproduce:
1. set LANG as none-US locale (ex. export LANG=ja_JP.eucJP)
2. execute mozilla
3. stop mozilla
4. execute moziila


Additional info:

Workaround:
apply follow patch.

--- /usr/bin/mozilla.orig       Thu Apr 15 20:23:43 2004
+++ /usr/bin/mozilla    Thu Apr 15 20:24:01 2004
@@ -175,8 +175,8 @@
                                                                     
      
 # check system locale
 MOZARGS=
-MOZLOCALE=`echo $LANG | sed "s|_\([^.]*\).*|-\1|g"`
-[ -f $MOZILLA_FIVE_HOME/chrome/$MOZLOCALE.jar ] && MOZARGS="-UILocale
$MOZLOCALE"
+#MOZLOCALE=`echo $LANG | sed "s|_\([^.]*\).*|-\1|g"`
+#[ -f $MOZILLA_FIVE_HOME/chrome/$MOZLOCALE.jar ] &&
MOZARGS="-UILocale $MOZLOCALE"
                                                                     
      
                                                                     
      
 # if there's no command line argument and there's not a running
Comment 3 Christopher Aillon 2005-03-08 23:33:36 EST
Going to mark dupe of another bug with slightly more info.

*** This bug has been marked as a duplicate of 134513 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:02:36 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.