This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 120974 - nested asssignment statement
nested asssignment statement
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: binutils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-15 15:58 EDT by d.binderman
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-19 03:37:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description d.binderman 2004-04-15 15:58:52 EDT
Description of problem:

I just had a look at Core2 Test2 package binutils-2.14.90.0.8-8.1

More deeply, I checked for nested assigments in assert statements. 

I found

[dcb@localhost BUILD]$ find binutils-2.14.90.0.8/ -name \*.c -print |
xargs grep -n "assert.*(.* = "
binutils-2.14.90.0.8/gas/config/tc-xtensa.c:3722:  assert (insn->ntok
= 1);    /* must be only one token here */

I'm not saying this is certainly wrong code, I'm only saying it is
IMHO deeply suspicious code. maybe something else was intended by the
programmer ?


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jakub Jelinek 2004-04-19 03:37:22 EDT
Mailed patch upstream.  We don't ship xtensa products, so it has no
relationship with the distro.

Note You need to log in before you can comment on or make changes to this bug.