Bug 1210496 - For a docker compute resource, the "Test Connection" button is always green
Summary: For a docker compute resource, the "Test Connection" button is always green
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Provisioning
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: Unspecified
Assignee: Dmitri Dolguikh
QA Contact: sthirugn@redhat.com
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-09 21:02 UTC by David Davis
Modified: 2017-02-23 20:10 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-12 16:02:38 UTC
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)
verification screenshot (62.06 KB, application/zip)
2015-07-09 19:40 UTC, sthirugn@redhat.com
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 10128 0 None None None 2016-04-22 16:01:52 UTC

Description David Davis 2015-04-09 21:02:25 UTC
Description of problem:

I notice when creating a new docker resource, the Test Connection button is always green. It's not like this for any other compute resource type.


Version-Release number of selected component (if applicable):

All.


How reproducible:

Always


Steps to Reproduce:
1. Using foreman-docker, create a new compute resource
2. Select Docker from the dropdown list
3. Note the color of the "Test Connection" button.

Actual results:

The button is green already.


Expected results:

It should not be green until you click it like with other compute resources such as libvirt. Green should only appear once the button is pressed and the connection was successful. 

Additional info:

Comment 1 RHEL Program Management 2015-04-09 21:03:19 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Bryan Kearney 2015-04-13 20:44:45 UTC
Created redmine issue http://projects.theforeman.org/issues/10128 from this bug

Comment 4 Dmitri Dolguikh 2015-06-10 11:59:03 UTC
PR: https://github.com/theforeman/foreman-docker/pull/117

Comment 5 Dmitri Dolguikh 2015-06-11 10:38:20 UTC
This has been fixed in the upstream, commit 906644157b0c015cd52df4d506eb386809cf4437.

Comment 7 Bryan Kearney 2015-06-26 14:32:28 UTC
Delivered in Snap10

Comment 8 sthirugn@redhat.com 2015-07-09 19:39:50 UTC
Verified in Sat 6.1 GA Snap 11

Comment 9 sthirugn@redhat.com 2015-07-09 19:40:11 UTC
Created attachment 1050428 [details]
verification screenshot

Comment 10 Bryan Kearney 2015-08-12 16:02:38 UTC
This bug was fixed in Satellite 6.1.1 which was delivered on 12 August, 2015.


Note You need to log in before you can comment on or make changes to this bug.