Bug 121052 - /usr/lib64/qt-3.3/mkspecs/linux-g++-64/qmake.conf contains lib6464
/usr/lib64/qt-3.3/mkspecs/linux-g++-64/qmake.conf contains lib6464
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-16 10:28 EDT by Martin Aumueller
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-20 09:48:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Martin Aumueller 2004-04-16 10:28:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux) (KHTML, like Gecko)

Description of problem:
/usr/lib64/qt-3.3/mkspec/linux-g++-64/qmake.conf is wrong in qt-devel-3.3.1-0.8 on x86_64:
- QMAKE_LIBDIR_X11        = /usr/X11R6/lib6464 instead of /usr/X11R6/lib64
- QMAKE_LIBDIR_QT         = $(QTDIR)/lib64 instead of $(QTDIR)/lib (as I think QTDIR should be set to /usr/lib64/qt-3.3)
- QMAKE_LIBDIR_OPENGL     = /usr/X11R6/lib6464 instead of /usr/X11R6/lib64

Additionally, I think that the link /usr/lib64/qt-3.3/mkspec/default should point to linux-g++-64, and not linux-g++ and that linux-g++ should be the unmodified version as distributed by Trolltech.



Version-Release number of selected component (if applicable):
qt-devel-3.3.1-0.8

How reproducible:
Always

Steps to Reproduce:
1. Install above mentioned package
2. Have a look at the above mentioned file and link
3.
    

Additional info:
Comment 1 Ngo Than 2004-04-20 09:48:10 EDT
it's fixed in 3.3.1-0.9 or newer. Thanks for your report

Note You need to log in before you can comment on or make changes to this bug.