Bug 121059 - [PATCH] LTC7645-ipr driver should be using request_bufflen instead of bufflen in queuecommand
[PATCH] LTC7645-ipr driver should be using request_bufflen instead of bufflen...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
powerpc Linux
medium Severity high
: ---
: ---
Assigned To: David Howells
Brian Brock
:
Depends On:
Blocks: 116727
  Show dependency treegraph
 
Reported: 2004-04-16 11:43 EDT by mark wisner
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-18 00:01:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to the IPR driver (1.46 KB, patch)
2004-04-16 11:50 EDT, mark wisner
no flags Details | Diff

  None (edit)
Description mark wisner 2004-04-16 11:43:14 EDT
The following has be reported by IBM LTC:  
ipr driver should be using request_bufflen instead of bufflen in
queuecommandHardware Environment:
p615

Software Environment:
RHEL 3 QU2 Beta

Additional Information:

The ipr driver is currently using scsi_cmd->bufflen in its
queuecommand routine.
The correct field to use is request_bufflen. Usually these values are
the same,
but if the eh thread gets invoked due to errors, test unit readies
would be sent
to the driver in which these are not the same and request_buffer is NULL,
resulting in the ipr driver calling pci_map_single will a NULL vaddr
and a stale
bufflen.Glen, please mirror this bug to Red Hat immediately. We would
like to get this 
into U2. Thanks.Created an attachment (id=3285)
Patch against current 2.4 ames bk

The attached patch fixes this bug.
Comment 1 mark wisner 2004-04-16 11:50:24 EDT
Created attachment 99484 [details]
Patch to the IPR driver
Comment 4 Ernie Petrides 2004-05-11 00:05:05 EDT
The patch in comment #1 has just been committed to the RHEL3 U3
patch pool this evening (in kernel version 2.4.21-15.3.EL).
Comment 5 Jay Turner 2004-08-18 00:01:16 EDT
Patch confirmed in kernel-2.4.21-19.EL.  Closing out.
Comment 6 John Flanagan 2004-09-02 00:31:21 EDT
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-433.html

Note You need to log in before you can comment on or make changes to this bug.