Bug 121066 - net-snmp build installed does not support dlmod
net-snmp build installed does not support dlmod
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: net-snmp (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jan Safranek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-16 14:15 EDT by John McCoy
Modified: 2010-05-06 07:31 EDT (History)
0 users

See Also:
Fixed In Version: net-snmp-5.0.9-2.30E.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-06 07:31:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John McCoy 2004-04-16 14:15:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
The net-snmp installed does not support dlmod.  The Intel/Dialogic 
boardwatch product requires Dynamic Modules.  I did find a bugzilla 
against this in AS 2.1 and it was closed claiming the next update 
would contain this fix.  It does not.  

The configure script provided in net-snmp does not properly work to 
enable this functionality.  In order to correct this problem, the 
following steps must be performed:
- From the net-snmp-5.0.9 directory run ./configure.  Answer all the 
questions with the default responses.
- edit the file: net-snmp-5.0.9/include/net-snmp /net-snmp-config.h
    -find the following code:
        /* Define if you have the dlopen function.  */
        /* #undef HAVE_DLOPEN */
    -change to
        /* Define if you have the dlopen function.  */
        #define HAVE_DLOPEN 1
        /* #undef HAVE_DLOPEN */
- make


Version-Release number of selected component (if applicable):
net-snmp-5.0.9

How reproducible:
Always

Steps to Reproduce:
1.snmpd -f -L -Ddlmod 

This will produce a message claiming that dlmod is not supported on 
this platform.    

Or use snmpd.conf to configure a loadable module

Actual Results:  This will produce a message claiming that dlmod is 
not supported on this platform. 

Expected Results:  should start the snmpd with dlmod logging 
enabled.  In the second case you should be able to do a snmpget but 
the module does not load.

Additional info:
Comment 1 Phil Knirsch 2004-06-25 08:21:59 EDT
Will be fixed in next Red Hat Enterprise Linux Quarterly update.

Read ya, Phil
Comment 2 Jan Safranek 2010-05-06 07:31:23 EDT
According to changelog, this bug is fixed since net-snmp-5.0.9-2.30E.4, previous maintainer just forgot to close the bug.

Note You need to log in before you can comment on or make changes to this bug.