This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 12107 - keyboard configuration issues with dead keys
keyboard configuration issues with dead keys
Status: CLOSED DUPLICATE of bug 36838
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-11 22:38 EDT by Red Hat Bugzilla
Modified: 2008-03-13 15:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-02 15:25:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Red Hat Bugzilla 2000-06-11 22:38:36 EDT
The initial keyboard configuration in the GUI install is both confusing and
broken.  There are three sections:  physical keyboard type (102 - key, 104
- key, etc.), Layout, and "Dead Keys".  The "Dead Keys" enable / disable
doesn't actually do anything however.

If I select US keyboard layout in the second section, and disable Dead Keys
in the third section, dead keys don't work (so far so good)

If I select US keyboard layout in the second section, and enable Dead Keys
in the third section, dead keys still don't work (not good)

If I select US keyboard with dead keys layout in the second section, and
enable Dead Keys in the third section, dead keys work (good)

If I select US keyboard with dead keys layout in the second section, and
disable Dead Keys in the third section, dead keys work (not even sure,
logically, what I should expect to happen in this case, but that seems
wrong ;-)

Basically, it seems like the Dead keys section isn't used at all, and only
the layout w/ or w/o dead keys matters for having dead keys.  Given that,
why not remove the third section from the screen completely, since it
doesn't do anything and just causes confusion (as in the 4th case above,
where dead keys layout is selected, but dead keys are disabled, or the 2nd
case above, where dead keys are enabled, but still don't work).
Comment 1 Red Hat Bugzilla 2000-06-17 11:32:23 EDT
Similar here - using the german keyboard layout, choosing disable dead keys does
nothing. 
In fact, when I start the system, kbdconfig says that the current mapping is
de-latin1 (instead of de-latin1-nodeadkeys). Correcting this (ie. choosing the
right mapping) is no problem, everything's okay then.
Comment 2 Red Hat Bugzilla 2000-06-19 11:33:54 EDT
I didn't test wheter dead keys work or not, but I caught an error message. It 
appears on VT1 when selecting "U.S.English" layout ( I don't really select it 
because it is selected by default ) and "Disable Dead Keys". The message is :
-----begin message - this line was not realy displayed :-) ------
The XKEYBOARD keymap compiler ( xkbcomp ) report:
>Error:   No Symbols named "nodeadkeys" in the include file "us"
>  Exiting
> Abandoning symbols file "default"
Error from xkbcomp not fatal to the X server.
Error loading new keyboard description
-----end of message-----
Comment 3 Red Hat Bugzilla 2000-06-26 00:08:19 EDT
This is still true in beta 2 -- the enable / disable is completely ignored, and
all that seems to be processed is the actual selected keymap.
Comment 4 Red Hat Bugzilla 2000-07-17 14:26:15 EDT
This is still true in beta3
Comment 5 Red Hat Bugzilla 2000-07-27 14:26:30 EDT
Please verify against beta 5.
Comment 6 Red Hat Bugzilla 2000-08-12 17:27:45 EDT
This is still messed up in RC1.

US English layout with deadkeys enabled		-> no dead keys
US English layout with deadkeys disabled		-> no dead keys
US English with deadkeys layout with deadkeys disabled	-> no dead keys
US English with deadkeys layout with deadkeys enabled	-> dead keys

What it looks like is that the deadkeys field is worthless and should just be
removed from the installer (obviously, this will have to wait for the next
release).  If the dead keys section were meaningful, US English layout with
deadkeys enabled should result in dead keys, and it doesn't.  What would make
the most sense would be to remove the dead keys section, and if people pick "US
English" for the layout, disable deadkeys, and if people pick "US English with
deadkeys" for the layout, enable deadkeys.
Comment 7 Red Hat Bugzilla 2001-01-03 16:52:38 EST
The deadkey button is not worthless.  The problem is that some keymaps have the
ability to use deadkeys and some do not.  For example, the "us" keymap does not
have the ability to use deadkeys, so yes, for this keymap, the deadkey button
has no effect.  
However, for a keymap such as "de", which is the German keyboard, the deadkey
button does have an effect.  
There were some bugs associated with the dead keys button and German keyboards,
but I have fixed those.  There is a need for a more intelligent keyboard
utility, but this will have to wait for a future release.
Comment 8 Red Hat Bugzilla 2001-10-23 15:02:03 EDT

*** This bug has been marked as a duplicate of 36838 ***

Note You need to log in before you can comment on or make changes to this bug.