Bug 121072 - (USB NET)bringing up eth1 fails with kernel-2.6.5-1.326 (usbnet)
(USB NET)bringing up eth1 fails with kernel-2.6.5-1.326 (usbnet)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-16 16:30 EDT by Paul Coleman
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-07 08:02:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Coleman 2004-04-16 16:30:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
when booting kernel-2.6.5-1.326 bringing up eth1 produces this error

Determining IP information for eth1...PING 66.57.200.1 (66.57.200.1)
56(84) bytes of data.
--- 66.57.200.1 ping statistics ---
3 packets transmitted, 0 received, +3 errors, 100% packet loss, time
2000ms, pipe 4 failed.

when booting kernel-2.6.5-1.309 eth1 comes up OK

Version-Release number of selected component (if applicable):
kernel-2.6.5-1.326

How reproducible:
Always

Steps to Reproduce:
1.boot kernel-2.6.5-1.326
2.
3.
    

Actual Results:  eth1 does not connect

Expected Results:  eth1 connects

Additional info:
/sbin/lsusb
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 002: ID 07b2:4100 Motorola BCS, Inc. SB4100 Cable Modem
Bus 001 Device 001: ID 0000:0000
Comment 1 Dave Jones 2004-04-16 18:52:24 EDT
what ethernet card ? lspci output please.
Comment 2 Dave Jones 2004-04-16 18:53:34 EDT
oh wait, does your usb cable modem usually show up as eth1 ?
Which driver does it use ?
Comment 3 Paul Coleman 2004-04-16 22:43:42 EDT
On this systen I also have a Via Rhine II that shows up as eth0. There
seemed to be a consistent problem with that driver that was related to
acpi so I switch to the usbnet connection USB CDC Ethernet Driver.
This has been reliable till kernel.315. The caveat being that
kernel.309 was the last to boot on my machine, an EPIA V with a C3.
Kernel.326 boots but the usbnet/CDC Ethernet Driver fails to connect.
Booting with the kernel.309 is OK. During bootup of kernel.326 the
activity led on the modem goes active but eth1 fails to connect. I
notice a variety of usb related complaints on the test list post
kernel.309.
Comment 4 Warren Togami 2004-04-18 16:30:16 EDT
Can you "lsmod |grep usb" and paste everything that shows up?
Comment 5 Paul Coleman 2004-04-18 20:16:34 EDT
/sbin/lsmod | grep usb
usbnet                 22412  0
mii                     3712  2 via_rhine,usbnet
crc32                   3968  2 via_rhine,usbnet
Comment 6 Pete Zaitcev 2004-04-19 14:51:27 EDT
I think it's a regression in the fresh 2.6 we picked up recently.
The USB subsystem seems toast. The best is to wait for the next
iteration, IMHO.
Comment 7 Miguel Dardenne 2004-04-30 21:16:11 EDT
I have the same problem with 2.6.5-1.327smp and my Motorola SB4200E
cablemodem. It worked fine before upgrade from 2.6.5-1.322smp.

/sbin/lsmod|grep usb gives
usbnet                 25228  0
mii                     7552  1 usbnet
crc32                   7808  1 usbnet
Comment 8 Nadav Kavalerchik 2004-05-03 14:57:22 EDT
i have the same problem with my AMBIT cable modem
( ifup eth0 - fails ) which works just fine on kernel 2.6.3.xxx
Comment 9 Miguel Dardenne 2004-05-07 07:18:48 EDT
Problem solved with 2.6.5-1.349smp in RawHide.

Note You need to log in before you can comment on or make changes to this bug.