Bug 121096 - amd64: anaconda exception
amd64: anaconda exception
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
: 121815 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-16 22:20 EDT by Robert de Rooy
Modified: 2007-11-30 17:10 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-01 18:17:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert de Rooy 2004-04-16 22:20:25 EDT
Description of problem:

Trying to install FC2T2 for x86_64 on a dual Opteron board from
Rioworks. http://www.rioworks.com/HDAMB.htm

Regular IDE, no SATA or Promise IDE-RAID.

When post install starts, I get an anaconda exception.
This is NOT a kickstart install, so there is no custom %POST section.

Text mode install worked fine, so it is just a graphical install problem.
Videocard is a Nvidia Quadro 4. I did run into another issue that I
had to manually select the monitor (DDC probe failed to detect the
monitor, while the same monitor was detected fine on another x86
system with FC1).

Version-Release number of selected component (if applicable):


How reproducible:

every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Traceback (most recent call last):
 File "/usr/lib/anaconda/gui.py", line 1047, in handleRenderCallback
  self.currentWindow.renderCallback()
 File "/usr/lib/anaconda/iw/progress_gui.py", line 242, in renderCallback
  self.intf.icw.nextClicked()
 File "/usr/lib/anaconda/gui.py", line 766, in nextClicked
  self.dispatch.gotoNext()
 File "/usr/lib/anaconda/dispatch.py", line 169, in gotoNext
  self.moveStep()
 File "/usr/lib/anaconda/dispatch.py", line 237, in moveStep
  rc = apply(func, self.bindArgs(args))
 File "/usr/lib/anaconda/packages.py", line 1093, in doPostInstall
  devnull = os.open("/dev/null", os.O_RDWR)
OSError: [Errno 1] Operation not permitted: '/dev/null'
Comment 1 Pete/Piet Delaney 2004-04-28 20:42:24 EDT
I just hit a very similar bug with Core 2 Test 3 on a MSI AMD64 board:

===============================================================================
Traceback (most recent call last):

File "/usr/lib/anaconda/gui.py", line 1044, in handleRenderCallback
  self.currentWindow.renderCallback()

File "/usr/lib/anaconda/iw/progress_gui.py", line 242, in renderCallback
  self.intf.icw.nextClicker()

File "/usr/lib/anacconda/gui.py, line 763, in nextClicked
  self.dispatch.gotoNext()

File "/usr/lib/anaconda/dispatch.py", line 237, in moveStep
  rc = apply(func, self.bindArgs(args))


File "/usr/lib/anaconda/dispatch.py", line 169, in gotoNext
  self.moveStep()

File "usr/lib/anaconda/packages.py, line 1111, in doPostInstall
  devnull = os.open("/dev/null", os.O_RDWR)

OSError: [Erro 1] Operation not permitted: '/dev/null'
===============================================================================
Comment 2 Jeremy Katz 2004-04-28 21:45:58 EDT
*** Bug 121815 has been marked as a duplicate of this bug. ***
Comment 3 Marc Von Ahn 2004-06-24 16:41:31 EDT
Doing a text install did not resolve this issue for me
Comment 4 Stuart Hayes 2004-09-22 12:27:58 EDT
We have seen this issue, too, on two different systems of the same 
model.  On our systems, we only saw the problem with SATA drives (on 
an ICH5R), not with SCSI drives.

The problem definitely happened in text mode as well as graphical 
mode.

On the 4th console (alt-F4), we see the message:

<2>EXT2-fs error (device ram0): ext2_check_page: bad entry in 
directory #29: rec_len is smaller than minimal - offset=1024, 
inode=0, rec_len=0, name_len=0

Not sure if that's related, but it doesn't look good.

On the 3rd console (alt-F3), the last message is:

* moving (1) to step setuptime
Comment 5 Stuart Hayes 2004-09-28 11:03:34 EDT
I have been unable to reproduce this on RHEL4 beta 1 so far.
Comment 6 Ben Greear 2004-11-18 14:24:38 EST
I also had failures with graphical install when using FC3 for x86-64.

In both cases (single Opteron and Dual Opteron system), the problem
appears to be that X will not start correctly, probably due to the
driver for the NVidia cards being somehow busted.

Text mode install works fine and once installed, X works fine too.

Note You need to log in before you can comment on or make changes to this bug.