Bug 121141 - 2.4.22-1.2179.nptl panic; mixing up SATA and /dev/hda
2.4.22-1.2179.nptl panic; mixing up SATA and /dev/hda
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
1
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-17 20:01 EDT by Roman Zielinski
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-19 16:40:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roman Zielinski 2004-04-17 20:01:33 EDT
Description of problem:

I upgraded FC1 to 2.4.22-1.2179.nptl and the kernle panics claiming
there is no /lib/modules/2.4.22-1.2179.nptl/modules.dep
(but it exists)

As I can see my SATA disk containing FC2-test2 has been discovered as
  SCSI /dev/sda (not as /dev/hde as earlier)  and it seems the loader
tried to use the root filesystem of FC2 instead of FC1, which I have
on an Par-ATA disk (hda).

After disconnectinmg the SATA-cable to the disk the system boots
correctly (root on /dev/hda2).

I.e I have: FC1 on /dev/hda, FC2 on SATA (/dev/hde or now /dev/sda)
Each disk has own MBR/Grup and does not know anything about the other
disk - I change boot device from BIOS-setup.



Version-Release number of selected component (if applicable):
2.4.22.1.2179.nptl


How reproducible:


Steps to Reproduce:
1. SATA-disk with FC2
2. ATA-disk with FC1/*.2179
3. Boot
  
Actual results:
Panic

Expected results:


Additional info:
Comment 1 Roman Zielinski 2004-04-18 05:59:20 EDT
Hi,
after further investigation the reason I got the the panic could be
that I (or rather xcdroast) activaded hdc=ide-scsi for my CDROM-RW
device, and loads scsi_mod. 
I tried to force loader to use root=/dev/hda2, but it still gets
confused claiming dupplicate root=LABEL=/ .
Comment 2 Roman Zielinski 2004-04-19 16:40:43 EDT
It's not a bug. I has same labels on both disks which confused the system.
The error occured when I installed ide-scsi for my CD-burner and the
SATA disk become visible.

Note You need to log in before you can comment on or make changes to this bug.