Bug 121185 - missing library refs
missing library refs
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
1
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-18 14:15 EDT by Jim Hanley
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-26 14:48:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jim Hanley 2004-04-18 14:15:24 EDT
Description of problem:
When running up2date in graphical mode, I get the error:
[jhanley@lava projects]$ up2date
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 1198, in ?
    sys.exit(main() or 0)
  File "/usr/sbin/up2date", line 852, in main
    from up2date_client import gui
  File "gui.py", line 16, in ?
  File "/usr/share/rhn/__init__.py", line 43, in ?
    File "/usr/share/rhn/__init__.py", line 43, in ?
ImportError: /usr/X11R6/lib/libXext.so.6: undefined symbol:
XESetFreeFontXESetCreateFont


Version-Release number of selected component (if applicable):
XFree86-libs-4.3.0-55
up2date-4.1.21-3
kernel-2.4.22-1.2174.nptl


How reproducible:
every time

Steps to Reproduce:
1. Run up2date with these libraries
2.
3.
  
Actual results:
exit missing library refs

Expected results:
run up2date in x mode

Additional info:
This is a minor problem since I can still run up2date with --nox and
it will run from command line.
Comment 1 Jim Hanley 2004-06-03 22:11:04 EDT
Seems as though I was able to fix this.

I had to force a reinstall of up2date-4.1.21-3.i386.rpm,
up2date-gnome-4.1.21-3.i386.rpm, XFree86-libs-4.3.0-55.i386.rpm, aand
gtk2-2.2.4-5.1.i386.rpm

It seems that some of the files were corrupted a while back from a
powerfailure.

On a related note, it would be nice if up2date could audit the
installed packages to compare checksums against the files inside a
package and the installed files for corruption (minus the config
files) so that something like this can quickly be found and fixed.

Note You need to log in before you can comment on or make changes to this bug.