Bug 121263 - 5 * local variable used before set
Summary: 5 * local variable used before set
Status: CLOSED DUPLICATE of bug 114372
Alias: None
Product: Fedora
Classification: Fedora
Component: Gtk-Perl   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Warren Togami
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-19 20:07 UTC by d.binderman
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-07 10:08:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description d.binderman 2004-04-19 20:07:31 UTC
Description of problem:

I just tried to compile Core2 Test2 package Gtk-Perl-0.7008-36.1

The compiler said

1.

GtkObject.xs(860): remark #592: variable "signals" is used before its
value is set

The source code is

                sv_setiv(s, signals);

Suggest init signals before first use.

2.

GdkImlib.xs(445): remark #592: variable "RETVAL" is used before its
value is set

The source code is

                sv_setpvn(RETVAL, mod, 256);

3.

GdkImlib.xs(457): remark #592: variable "RETVAL" is used before its
value is set
GdkImlib.xs(469): remark #592: variable "RETVAL" is used before its
value is setGnomeDockLayout.xs(57): remark #592: variable "RETVAL" is
used before its value

Duplicates


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Terje Bless 2004-09-11 14:03:04 UTC
Duplicate of Bug #114372?

Comment 2 Warren Togami 2005-09-07 10:08:29 UTC

*** This bug has been marked as a duplicate of 114372 ***


Note You need to log in before you can comment on or make changes to this bug.