Bug 121268 - gpilot conduits unable to instantuate on x86_64
gpilot conduits unable to instantuate on x86_64
Product: Fedora
Classification: Fedora
Component: gnome-pilot-conduits (Show other bugs)
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Depends On:
  Show dependency treegraph
Reported: 2004-04-19 17:00 EDT by Justin M. Forbes
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-10-29 16:54:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
gnome-pilot-2.0.10-lib64.patch (3.90 KB, patch)
2004-06-02 00:25 EDT, Justin M. Forbes
no flags Details | Diff
updated spec for gnome-pilot (7.30 KB, patch)
2004-06-02 00:26 EDT, Justin M. Forbes
no flags Details | Diff
gnome-pilot-2.0.10-lib64.patch (7.06 KB, patch)
2004-06-02 00:27 EDT, Justin M. Forbes
no flags Details | Diff
Updated spec for gnome-pilot-conduits (1.98 KB, patch)
2004-06-02 00:27 EDT, Justin M. Forbes
no flags Details | Diff
evolution-1.4.6-lib64conduit.patch (4.17 KB, patch)
2004-06-02 00:28 EDT, Justin M. Forbes
no flags Details | Diff
updated spec for evolution (23.43 KB, patch)
2004-06-02 00:29 EDT, Justin M. Forbes
no flags Details | Diff

  None (edit)
Description Justin M. Forbes 2004-04-19 17:00:52 EDT
gpilot gives "Unable to instantiate (insert Conduit name here)
conduit" for all conduits tested so far (Calendar, Todo, Memo, Backup,
and Contacts) on x86_64 systems.  Adding a new device was able to pull
the userid from the treo 600, so it seems to be isolated to conduit.
Comment 1 Justin M. Forbes 2004-06-02 00:23:31 EDT
Okay, got it all fixed.  The issue lies in the way
/usr/share/gnome-pilot/conduits/*.conduit are created.  The fix
requires a patch against each conduit's .conduit.in file and Makefile.
 Attached are updated specs and patches for gnome-pilot,
gnome-pilot-conduit, and evolution.  This gets all of them it seems,
and will build and function appropriately on lib and lib64 systems. 
Please push when you can, as gnome-pilot is essentially useless on
x86_64 until these are applied.
Comment 2 Justin M. Forbes 2004-06-02 00:25:14 EDT
Created attachment 100780 [details]

This fixes the default .conduits paths in /usr/share/gnome-pilot/conduits/
Comment 3 Justin M. Forbes 2004-06-02 00:26:25 EDT
Created attachment 100781 [details]
updated spec for gnome-pilot
Comment 4 Justin M. Forbes 2004-06-02 00:27:32 EDT
Created attachment 100782 [details]

Patch to fix paths in /usr/share/gnome-pilot/conduits/*.conduit
Comment 5 Justin M. Forbes 2004-06-02 00:27:57 EDT
Created attachment 100783 [details]
Updated spec for gnome-pilot-conduits
Comment 6 Justin M. Forbes 2004-06-02 00:28:51 EDT
Created attachment 100784 [details]

patch to fix the paths in /usr/share/gnome-pilot/conduits/*.conduit
Comment 7 Justin M. Forbes 2004-06-02 00:29:14 EDT
Created attachment 100785 [details]
updated spec for evolution
Comment 8 Justin M. Forbes 2004-06-02 00:33:17 EDT
Added patch in the evolution.spec is patch12
Comment 9 Justin M. Forbes 2004-07-08 18:17:32 EDT
Any chance of getting these patches pushed? FC3 release cycle is
kicking up now, and it is easy to forget about these things.  Until
this is patched, current x86_64 users cannot use any conduits.
Comment 10 Dave Malcolm 2004-08-19 23:04:34 EDT
Sorry it's taken so long for me to comment on this bug.

Attachment id=100780 has been in gnome-pilot since 2.0.10-8
Attachment id=100781 appears to simply add that patch; this was taken
care of at that time.

I've now applied attachments id=100782 and 100783 to
gnome-pilot-conduits and rebuilt into Rawhide as version 2.0.10-4

Attachment ids 100784 and 100785 remain to be applied to the 1.4
branch.  Looking at the latest Evolution package (1.5.93), the
conduits appear to use @privconduitdir@ which is generated from
${libdir}, so I believe that we don't need to apply these to fix the
1.5 branch of Evolution.

Does this functionality work in Evolution 1.5.93 on x86_64 with the
latest rawhide packages?

Comment 12 John Thacker 2006-10-29 16:54:13 EST
Closing per lack of response to previous request for information.  Note that FC3
and FC4 are supported by Fedora Legacy for security fixes only.  Please test
this on FC5 or FC6.  If it still occurs there, please reopen and change the
version to fc5 or fc6.  Otherwise, if this is a security issue, please reassign
the bug to Fedora Legacy.  Thanks, and we apologize for not getting to this bug

Note You need to log in before you can comment on or make changes to this bug.