Bug 121280 - mail command fails under cron
mail command fails under cron
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: vixie-cron (Show other bugs)
2.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks: 170792
  Show dependency treegraph
 
Reported: 2004-04-19 19:21 EDT by Rick Greene
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version: vixie-cron-4.1-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-04 13:54:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rick Greene 2004-04-19 19:21:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.2)
Gecko/20040301

Description of problem:
If I execute the following from a user's interactive shell:

echo "test email" | mail -s"test subject" user@domain.com

It works fine...mail shows up.  If I put the same command line in a
cron entry for that same user (and user is active in /etc/cron.allow),
it fails to generate an email.  Adding ">/tmp/cron.email.log 2>&1"
produces the following output:

Memory fault

I've tried putting the command in a simple shell script, and again it
works from interactive but not from cron.  Even specifying /bin/mail
doesn't help...it still produces "Memory fault".

Version-Release number of selected component (if applicable):
vixie-cron-3.0.1-63

How reproducible:
Always

Steps to Reproduce:
see above description
    

Additional info:
Comment 1 Rick Greene 2004-04-20 13:59:13 EDT
a web search turned up a vague statement about a bug in some versions
of cron under the 2.4 linux kernel.  The statement talked about cron
not handling stdin, stdout, and stderr correctly so that subsequent
spawned jobs fail.  The link is
http://www.uwsg.iu.edu/hypermail/linux/kernel/0109.2/1249.html  It's
an older message (Sep 2001) so I don't know if it is still valid or
not, but I've been unable to find any place where vixie-cron is
updated beyond what RedHat AS2.1 update 3 provides.
Comment 3 Jens Petersen 2004-06-30 13:42:52 EDT
This should be fixed first in vixie-cron-3.0.1-94 in FC/devel
(aka rawhide).
Comment 4 Rick Greene 2004-06-30 13:50:37 EDT
Are there any workarounds?

Is there any expected date as to when this would be
available/supported under RH AS 2.1?
Comment 5 Jens Petersen 2004-06-30 13:56:13 EDT
I think this is a duplicate of bug 53078.

Hopefully there will be an update for RHEL 2.1 soon
to fix this and other issues. :)
Comment 6 Jason Vas Dias 2004-08-04 11:07:12 EDT
This is now fixed in vixie-cron-4.1-1+(7).
Comment 7 Rick Greene 2004-08-04 11:21:53 EDT
I do not see this available through rhn.redhat.com under the AS 2.1
channel.  When will this be available for download for AS 2.1?
Comment 8 Jason Vas Dias 2004-08-04 13:54:05 EDT
 This bug is closed because it is fixed in the latest version 
 of cron (vixie-cron-4.1) .

 To get this 'new major release' update pushed to the RHEL 2.1-AS
 updates channel, please contact your Red Hat support representative;
 I can only submit updates to 2.1 if they are specifically requested
 by support.

Note You need to log in before you can comment on or make changes to this bug.