This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 121299 - (NET 3C59X) eth0 fails to activate with dhcp
(NET 3C59X) eth0 fails to activate with dhcp
Status: CLOSED DUPLICATE of bug 107389
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-20 03:58 EDT by Peter Edwards
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dmesg file (7.37 KB, text/plain)
2004-05-07 09:02 EDT, Peter Edwards
no flags Details

  None (edit)
Description Peter Edwards 2004-04-20 03:58:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; 
FunWebProducts; Hotbar 4.4.5.0)

Description of problem:
I have a pentium III computer with a 3Com 3C905TX-based Ethernet 
Adapter (Generic) or as linux calls it (boomrang) network card that 
will not obtain an ip address via dhcp so every time i try to 
activate it it fails. but it works with a static ip. I took a look at 
its irq settings and it said that its irq number was unknown. I am 
using fedora core 2 test 2 that I got from everything linux in sydney 
australia and have not added to it at all execept off the install 
cds. I also had this problem with fedora core 1 but not with redhat 
9. also it is a duel boot wih windows xp on another partition.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install fedora on computer and go to network.
2. Choose to obtain ip address from dhcp and the same for dns.
3. Save and try to activate and the problem comes up.
    

Actual Results:  eth0 fails to activate

Expected Results:  eth0 should activate

Additional info:
Comment 1 Harald Hoyer 2004-04-21 10:14:22 EDT
turn on DHCP, run
# ifup eth0
# ifconfig

and paste in the output here, please
Comment 2 Peter Edwards 2004-04-21 11:06:05 EDT
The output of those commands are:

[root@localhost root]# ifup eth0

Determining IP information for eth0... failed.
[root@localhost root]# ifconfig

eth0      Link encap:Ethernet  HWaddr 00:10:5A:9C:A8:6A
          inet6 addr: fe80::210:5aff:fe9c:a86a/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:1 dropped:0 overruns:3 carrier:3
          collisions:0 txqueuelen:1000
          RX bytes:8341 (8.1 Kb)  TX bytes:0 (0.0 b)
          Interrupt:11 Base address:0xd000
 
lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:5187 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5187 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:5375768 (5.1 Mb)  TX bytes:5375768 (5.1 Mb)


Comment 3 Harald Hoyer 2004-04-22 04:14:02 EDT
so, it seems, you have no dhcp server in your network?
Comment 4 Peter Edwards 2004-04-22 07:04:32 EDT
Sorry I forgot to mention I am trying to activate the network card to 
work with a speedtouch 530 Telstra bigpond adsl modem
Comment 5 Harald Hoyer 2004-04-22 07:25:16 EDT
then do not check "DHCP" for it...

I don't know... maybe this helps:
http://speedtouchconf.sourceforge.net/
Comment 6 Alan Cox 2004-05-02 20:13:24 EDT
Actually the clue is in the trace

          RX packets:1 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:1 dropped:0 overruns:3 carrier:3

Its either negotiated the link wrong or is hitting a dodgy cable.
Either way its hardware or kernel side. What is in dmesg
Comment 7 Peter Edwards 2004-05-07 09:02:54 EDT
Created attachment 100075 [details]
dmesg file

Hi Alan
The dmesg file I think you mean is attached to this message. I hope you can
help. I don't think it is a hardware fault because it works with every other
Operating System I install. Please reply asap as I want to start installing
things off the web and it is too hard to swap between os's to search for thier
dependencies.
Comment 8 Alan Cox 2004-05-07 11:41:44 EDT
Kernel I think. I found a matching bug report about dhcp with 3com
3c905tx cards. 
Comment 9 Alan Cox 2004-05-22 12:32:29 EDT

*** This bug has been marked as a duplicate of 107389 ***
Comment 10 Red Hat Bugzilla 2006-02-21 14:02:41 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.