Bug 121309 - No SU functions in user in kde menu's while selinux is in enforcing mode
No SU functions in user in kde menu's while selinux is in enforcing mode
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: policy (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
: SELinux
: 122872 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-20 06:59 EDT by jim tate
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-03 16:12:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jim tate 2004-04-20 06:59:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b)
Gecko/20040316

Description of problem:
While a user in kde-any ver. if Selinux is in enforcing mode, 
You cannot get any of the SU function to work. If you click on 
a SU application to run , it will attempt to run , but you will not
get the Kde-SU window to type in SU password, after about 10 sec.it
will just stop running.
If you switch Selinux to SELINUX=permissive or disabled, then 
you can run the SU applications as user.

Version-Release number of selected component (if applicable):
3.2.2

How reproducible:
Always

Steps to Reproduce:
1.Goto kde menu click on Menu/icons for any SU application.
2.
3.
    

Actual Results:  No use of SU applications.

Expected Results:  Be able to run SU application as user after
entering SU password.

Additional info:
Comment 1 Ben Levenson 2004-05-26 16:38:32 EDT
*** Bug 122872 has been marked as a duplicate of this bug. ***
Comment 2 Ben Levenson 2004-05-26 17:34:23 EDT
please attach the relevant avc messages.
Comment 3 Daniel Walsh 2005-01-03 16:12:37 EST
This works fine in FC3/RHEL4.

Note You need to log in before you can comment on or make changes to this bug.