Bug 121338 - OpenOffice.org script grabs wrong gui language
OpenOffice.org script grabs wrong gui language
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
: 122390 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-20 12:10 EDT by Timo Pykalainen
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-25 16:53:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Timo Pykalainen 2004-04-20 12:10:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040116

Description of problem:
OpenOffice.org ooffice script doesn't choose the gui language
correctly. in my case I have the following locales in .i18n
LANG=en_US.UTF-8
LC_CTYPE="zh_CN.GB18030"
LC_NUMERIC="fi_FI"
LC_TIME="en_US"
LC_COLLATE="fi_FI"
LC_MONETARY="fi_FI"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="fi_FI"
LC_NAME="fi_FI"
....

I should get the menus in English but after upgrading OpenOffice.org 
to 1.1.0-15 the /usr/bin/ooffice grabs the gui language from the
locale in wrong way. However it doesn't work the way it should, for
some reason in my case it chooses Chinese (as in LC_CTYPE is for
inputing Chinese) eventhough the ooffice script grabs the locale as
en-us. I fixed this by editing the /usr/bin/office script and hard
coded the language value as 'en'. Previous version of OpenOffice saved
the menu locale (from the first startup) in the file in home
directory. Now it handles it automatically.

Moreover the /usr/bin/ooffice script has an annoyance regarding the
gui language grabbing as it saves an temp file in your home directory,
so when you start OpenOffice.org the temp file flashes in your e.g.
nautilus window. 

Version-Release number of selected component (if applicable):
1.1.0-15

How reproducible:
Always

Steps to Reproduce:
1.set the locales as LANG=en_US.UTF-8,
LC_CTYPE="zh_CN.GB18030", and LC_MESSAGES="en_US.UTF-8"
2. start OpenOffice.org
    

Actual Results:  The menu language is wrong, in my case Chinese.

Expected Results:  Menus should be in English as set in
LC_MESSAGES="en_US.UTF-8"

Additional info:
Comment 1 Dan Williams 2004-05-04 09:47:02 EDT
*** Bug 122390 has been marked as a duplicate of this bug. ***
Comment 2 Carlos Rodrigues 2004-07-09 14:39:45 EDT
This is fixed in FC2.

Note You need to log in before you can comment on or make changes to this bug.