Bug 12138 - every /etc/ file backed up in upgrade
Summary: every /etc/ file backed up in upgrade
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
: 13151 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-06-12 18:21 UTC by Telsa Gwynne
Modified: 2007-04-18 16:27 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-17 22:21:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Telsa Gwynne 2000-06-12 18:21:19 UTC
Upgrade of largely vanilla RH 6.2 to Winston. 
Upgrade.log had backup of practically every file in /etc saved as
.rpmorig. Whilst this can be good, most of these files had never
even been touched. A touch wholesale, really.

Comment 1 Brock Organ 2000-06-26 19:06:48 UTC
verified ... even files that did not change were backed up ... (such as
/etc/host.conf & /etc/host.conf.rpmnew)

Comment 2 Pekka Savola 2000-07-03 14:20:48 UTC
*** Bug 13151 has been marked as a duplicate of this bug. ***

Comment 3 Pekka Savola 2000-07-03 14:22:57 UTC
This happens with beta2 too (see some notes in duplicate #13151).


Comment 4 Jeremy Katz 2000-07-06 05:36:30 UTC
This appears to be fixed in beta3 from my upgrade test

Comment 5 Pekka Savola 2000-07-07 18:11:40 UTC
Not here.  I did two upgrades, but both times junk in /etc was created.

Comment 6 Bill Nottingham 2000-07-10 16:50:26 UTC
This should be fixed with the latest initscripts (5.30-1 or greater).

Comment 7 Brock Organ 2000-08-06 21:49:45 UTC
using initscripts-5.39-1 (pinstripe beta), most files were not duplicated as
.rpmnew, except in the following 3 files during a minimal 6.2 -> pinstripe
upgrade:

/etc/hosts.allow
/etc/hosts.deny
/etc/printcap

These three files were duplicated even though they are the same file ...

Comment 8 Brock Organ 2000-08-15 14:44:47 UTC
Here are the corresponding upgrade.log entries for the setup package showing the
saving of the files ...

Upgrading setup.                                                                
warning: /etc/csh.cshrc created as /etc/csh.cshrc.rpmnew                        
warning: /etc/csh.login created as /etc/csh.login.rpmnew                        
warning: /etc/exports created as /etc/exports.rpmnew                            
warning: /etc/filesystems created as /etc/filesystems.rpmnew                    
warning: /etc/group created as /etc/group.rpmnew                                
warning: /etc/host.conf created as /etc/host.conf.rpmnew                        
warning: /etc/hosts.allow created as /etc/hosts.allow.rpmnew                    
warning: /etc/hosts.deny created as /etc/hosts.deny.rpmnew                      
warning: /etc/inputrc saved as /etc/inputrc.rpmorig                             
warning: /etc/motd saved as /etc/motd.rpmorig                                   
warning: /etc/passwd created as /etc/passwd.rpmnew                              
warning: /etc/printcap created as /etc/printcap.rpmnew                          
warning: /etc/profile created as /etc/profile.rpmnew                            
warning: /etc/protocols saved as /etc/protocols.rpmorig                         
warning: /etc/securetty saved as /etc/securetty.rpmorig                         
warning: /etc/services saved as /etc/services.rpmorig                           
warning: /var/log/lastlog created as /var/log/lastlog.rpmnew

Comment 9 Michael Fulbright 2000-08-17 22:21:48 UTC
Fixed.


Note You need to log in before you can comment on or make changes to this bug.