Bug 121389 - Cannot add packages to a existing system
Cannot add packages to a existing system
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-packages (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-20 21:28 EDT by Philippe Hertzog
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 15:49:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philippe Hertzog 2004-04-20 21:28:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
I try to update my system with some new packages using
system-config-packages but it still display the following message:

"Packages not found"

Version-Release number of selected component (if applicable):
system-config-packages-1.2.12-1

How reproducible:
Always

Steps to Reproduce:
1. Open system-config-display
2. Try to add xorg-x11-xdm package
    

Actual Results:  Message "Packages not found" is displayed
   system-config-display 1.0.13 2 and xorg-x11-libs 6.7.0 0.5 required

Expected Results:  package should be found

Additional info:

open a root terminal:
# rpm -q xorg-x11-libs
xorg-x11-libs-6.7.0-0.5
# rpm -q system-config-display
system-config-display-1.0.13-2
Comment 1 Michael Schwendt 2004-07-16 06:05:08 EDT
system-config-packages-1.2.12-1

Is this the same as or related to what I get in FC3 Test1 when trying
to add KDE?

Packages Not Found
...
Unlocatable package         Required by
/usr/X11R6/bin/xauth        ('xorg-x11','6.7.0','6')
system-config-securitylevel ('firstboot','1.3.16','1')

Console output:
* using xorg-x11-xdm-0:6.7.0-6.i386 to satisfy /etc/X11/xdm/Xservers
* using kdelibs-6:3.2.3-4.i386 to satisfy kdelibs-6:3.2.3
* using lm_sensors-0:2.8.6-2.i386 to satisfy libsensors.so.3
* using kdepim-6:3.2.3-1.i386 to satisfy libkabinterfaces.so.1
* using net-snmp-0:5.1.1-4.i386 to satisfy libnetsnmp.so.5
('/usr/X11R6/bin/xauth', None)
('system-config-securitylevel', None)
Comment 2 Aaron Schlaegel 2005-01-13 03:24:07 EST
I get the same error when I attempt to add Development Tools on an up
to date system.

The following packages could not be found on your system. 
Installation cannot continue until they are installed.
 libselinux ('system-config-securitylevel', '1.4.18','2')
 krb5-libs ('krb5-workstation','1.3.6','2')
 pam ('sane-backends','1.0.15','1.4')
 libxml2 ('libxml2-python','2.6.16','3')

`rpm -q libselinux system-config-securitylevel krb5-libs
krb5-workstation pam sane-backends libxml2 libxml2-python`
> libselinux-1.19.1-8.i386
> system-config-securitylevel-1.4.18-2.i386
> krb5-libs-1.3.6-2.i386
> krb5-workstation-1.3.6-2.i386
> pam-0.77-66.1.i386
> sane-backends-1.0.15-1.4.i386
> libxml2-2.6.16-3.i386
> libxml2-python-2.6.16-3.i386 
Comment 3 Jeremy Katz 2005-09-21 15:49:08 EDT
This is caused by updates which s-c-p never finds out about.  The next gen tool
(which will land in FC5) will not have this problem

Note You need to log in before you can comment on or make changes to this bug.