Bug 121405 - Oops in the bluetooth kernel driver, while running kudzu.
Oops in the bluetooth kernel driver, while running kudzu.
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-21 02:33 EDT by Tomislav Vujec
Modified: 2015-01-04 17:05 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-29 08:53:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomislav Vujec 2004-04-21 02:33:47 EDT
Description of problem:

During the system boot procedure, I get the oops in the kernel
bluetooth driver, when kudzu checks for hardware. Here is the exact
message from my syslog:

Apr 21 06:49:15 saturn kernel: usb 2-2: USB disconnect, address 2
Apr 21 06:49:15 saturn kernel: Unable to handle kernel paging request
at virtual address 6b6b6bb7
Apr 21 06:49:15 saturn kernel:  printing eip:
Apr 21 06:49:15 saturn kernel: 0221e46c
Apr 21 06:49:15 saturn kernel: *pde = 00000000
Apr 21 06:49:15 saturn kernel: Oops: 0002 [#1]
Apr 21 06:49:15 saturn kernel: CPU:    0
Apr 21 06:49:15 saturn kernel: EIP:    0060:[<0221e46c>]    Not tainted
Apr 21 06:49:15 saturn kernel: EFLAGS: 00010246   (2.6.5-1.332)
Apr 21 06:49:15 saturn kernel: EIP is at class_device_del+0x25/0xa2
Apr 21 06:49:15 saturn kernel: eax: 6b6b6bb7   ebx: 6b6b6bb7   ecx:
00000000   edx: ffff0001
Apr 21 06:49:15 saturn kernel: esi: 6b6b6b6b   edi: 4125bc70   ebp:
0000000a   esp: 41e77f0c
Apr 21 06:49:15 saturn kernel: ds: 007b   es: 007b   ss: 0068
Apr 21 06:49:15 saturn kernel: Process khubd (pid: 5,
threadinfo=41e77000 task=39fba030)
Apr 21 06:49:15 saturn kernel: Stack: 4125ba80 4125ba80 41360408
428ab42c 418c9c80 4284d9d8 413603f8 4284e960
Apr 21 06:49:15 saturn kernel:        0225c335 41360408 4284e980
0221dbfc 0234d400 0234d44c 0221dcfc 41360408
Apr 21 06:49:15 saturn kernel:        02344ea8 41863964 0221d06a
41360408 41863880 ffffffff 0221d093 00000001
Apr 21 06:49:15 saturn kernel: Call Trace:
Apr 21 06:49:15 saturn kernel:  [<428ab42c>]
hci_unregister_dev+0x8/0x5b [bluetooth]
Apr 21 06:49:15 saturn kernel:  [<4284d9d8>]
hci_usb_disconnect+0x30/0x54 [hci_usb]
Apr 21 06:49:15 saturn kernel:  [<0225c335>]
usb_unbind_interface+0x2c/0x50
Apr 21 06:49:15 saturn kernel:  [<0221dbfc>]
device_release_driver+0x3c/0x46
Apr 21 06:49:15 saturn kernel:  [<0221dcfc>] bus_remove_device+0x47/0x80
Apr 21 06:49:15 saturn kernel:  [<0221d06a>] device_del+0x66/0x87
Apr 21 06:49:15 saturn kernel:  [<0221d093>] device_unregister+0x8/0x10
Apr 21 06:49:15 saturn kernel:  [<0226276d>] usb_disable_device+0x62/0x8a
Apr 21 06:49:15 saturn kernel:  [<0225ccae>] usb_disconnect+0x9d/0xd2
Apr 21 06:49:15 saturn kernel:  [<0225ec9a>]
hub_port_connect_change+0x4b/0x210
Apr 21 06:49:15 saturn kernel:  [<0225f031>] hub_events+0x1d2/0x3fd
Apr 21 06:49:15 saturn kernel:  [<0225f27a>] hub_thread+0x1e/0xd0
Apr 21 06:49:15 saturn kernel:  [<0211a4f6>] default_wake_function+0x0/0xc
Apr 21 06:49:15 saturn kernel:  [<0225f25c>] hub_thread+0x0/0xd0
Apr 21 06:49:15 saturn kernel:  [<021041d9>] kernel_thread_helper+0x5/0xb
Apr 21 06:49:15 saturn kernel:
Apr 21 06:49:15 saturn kernel: Code: 0f c1 10 85 d2 0f 85 1a 02 00 00
8b 07 8b 57 04 89 02 89 3f

Disabling bluetooth device makes the oops disappear. I also had an
oops with the previous kernel packages (2.6.5-1.327 2.6.5-1.326). It
was a different one, but looking at the trace, it seems it looks a lot
like the current one:

Apr 19 04:48:22 tomislav kernel: usb 2-2: USB disconnect, address 2
Apr 19 04:48:22 tomislav kernel: Unable to handle kernel NULL pointer
dereference at virtual address 00000080
Apr 19 04:48:22 tomislav kernel:  printing eip:
Apr 19 04:48:22 tomislav kernel: 0219d833
Apr 19 04:48:22 tomislav kernel: *pde = 00000000
Apr 19 04:48:22 tomislav kernel: Oops: 0002 [#1]
Apr 19 04:48:22 tomislav kernel: CPU:    0
Apr 19 04:48:22 tomislav kernel: EIP:    0060:[<0219d833>]    Not tainted
Apr 19 04:48:22 tomislav kernel: EFLAGS: 00010246   (2.6.5-1.326)
Apr 19 04:48:22 tomislav kernel: EIP is at sysfs_hash_and_remove+0x22/0x7b
Apr 19 04:48:22 tomislav kernel: eax: 00000000   ebx: 00000080   ecx:
00000080   edx: 00000077
Apr 19 04:48:22 tomislav kernel: esi: 00000000   edi: 0230d031   ebp:
3fd1f780   esp: 41e70ef8
Apr 19 04:48:22 tomislav kernel: ds: 007b   es: 007b   ss: 0068
Apr 19 04:48:22 tomislav kernel: Process khubd (pid: 5,
threadinfo=41e70000 task=39fbc030)
Apr 19 04:48:22 tomislav kernel: Stack: 428b2338 428b22c0 3de379f0
0000000a 0221c465 3de37800 3de37800 3dd06b90
Apr 19 04:48:22 tomislav kernel:        428a942c 3df66c00 4287c9da
3dd06b80 4287d920 0225a111 3dd06b90 4287d940
Apr 19 04:48:22 tomislav kernel:        0221bb84 0234a380 0234a3cc
0221bc84 3dd06b90 02341e28 3dd014e4 0221aff2
Apr 19 04:48:22 tomislav kernel: Call Trace:
Apr 19 04:48:22 tomislav kernel:  [<0221c465>] class_device_del+0x81/0xa2
Apr 19 04:48:22 tomislav kernel:  [<428a942c>]
hci_unregister_dev+0x8/0x5b [bluetooth]
Apr 19 04:48:22 tomislav kernel:  [<4287c9da>]
hci_usb_disconnect+0x30/0x56 [hci_usb]
Apr 19 04:48:22 tomislav kernel:  [<0225a111>]
usb_unbind_interface+0x2c/0x50
Apr 19 04:48:22 tomislav kernel:  [<0221bb84>]
device_release_driver+0x3c/0x46
Apr 19 04:48:22 tomislav kernel:  [<0221bc84>] bus_remove_device+0x47/0x80
Apr 19 04:48:22 tomislav kernel:  [<0221aff2>] device_del+0x66/0x87
Apr 19 04:48:22 tomislav kernel:  [<0221b01b>] device_unregister+0x8/0x10
Apr 19 04:48:22 tomislav kernel:  [<02260549>]
usb_disable_device+0x62/0x8a
Apr 19 04:48:22 tomislav kernel:  [<0225aa8a>] usb_disconnect+0x9d/0xd2
Apr 19 04:48:22 tomislav kernel:  [<0225ca76>]
hub_port_connect_change+0x4b/0x210
Apr 19 04:48:22 tomislav kernel:  [<0225ce0d>] hub_events+0x1d2/0x3fd
Apr 19 04:48:22 tomislav kernel:  [<0225d056>] hub_thread+0x1e/0xd0
Apr 19 04:48:23 tomislav kernel:  [<0211a4ba>]
default_wake_function+0x0/0xc
Apr 19 04:48:23 tomislav kernel:  [<0225d038>] hub_thread+0x0/0xd0
Apr 19 04:48:23 tomislav kernel:  [<021041d9>]
kernel_thread_helper+0x5/0xb
Apr 19 04:48:23 tomislav kernel:
Apr 19 04:48:23 tomislav kernel: Code: ff 8e 80 00 00 00 78 51 89 fa
89 e8 e8 7a ff ff ff 3d 18 fc

I had USB/Bluetooth related oopses in earlier kernels (2.6.5-1.322 and
2.6.5-1.315) in usb_set_interface. However, I didn't notice oopses in
the kernel 2.6.5-1.319, but it might be that the bluetooth was
disabled while I was running it.

Bluetooth was last time working for me in the kernel 2.6.3-2.1.253.2.1.

Version-Release number of selected component (if applicable):
kernel-2.6.5-1.332 kudzu-1.1.57-1

How reproducible:
Every time.

Steps to Reproduce:
1. Enable bluetooth USB device.
2. Boot the system.

or

1. Boot the system with USB bluetooth device disabled
2. Enable bluetooth device.
3. Run kudzu -p.
  
Actual results:
I got mentioned oops in the syslog. Also, processes like kudzu, or
even lsusb -v hang if they are executed after the oops. 

Expected results:
Well, that is the easy one. No oops, and the bluetooth working :-)

Additional info:
None.
Comment 1 Dave Jones 2004-11-27 18:53:24 EST
still a problem with the 2.6.9 kernel update ?
bluetooth seems to be working fine for me.
Comment 2 Tomislav Vujec 2004-11-29 08:53:31 EST
Sorry for leaving this open, it works for me since upgrading to FC3 test2.

Note You need to log in before you can comment on or make changes to this bug.