Bug 121425 - (NFS) mv process hung w/ kernel error on mv nfs->local
(NFS) mv process hung w/ kernel error on mv nfs->local
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-21 10:12 EDT by P Jones
Modified: 2015-01-04 17:05 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-10 08:46:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from "tcpdump -vv port nfs" (49.75 KB, text/plain)
2004-08-31 22:51 EDT, Eugene Kanter
no flags Details

  None (edit)
Description P Jones 2004-04-21 10:12:27 EDT
Description of problem:
Apr 21 10:08:14 rocks kernel: kernel BUG at include/linux/highmem.h:59!


Version-Release number of selected component (if applicable):


How reproducible:
Not very

Steps to Reproduce:
1. Running a NFS server un RH9, 
2. mounted (via autofs via YP) nfs server.
3. Er, used the maching till I got the message :(
  

Apr 21 10:08:14 rocks kernel: nfs: server
starfish.internal.datastacks.com not responding, timed out
Apr 21 10:08:14 rocks kernel: ------------[ cut here ]------------
Apr 21 10:08:14 rocks kernel: kernel BUG at include/linux/highmem.h:59!
Apr 21 10:08:14 rocks kernel: invalid operand: 0000 [#1]
Apr 21 10:08:14 rocks kernel: CPU:    0
Apr 21 10:08:14 rocks kernel: EIP:    0060:[<43ac84b4>]    Not tainted
Apr 21 10:08:14 rocks kernel: EFLAGS: 00210206   (2.6.4-1.281)
Apr 21 10:08:14 rocks kernel: EIP is at nfs_readpage_sync+0x2c6/0x339
[nfs]Apr 21 10:08:14 rocks kernel: eax: 5a5a6a5a   ebx: 5a5a5a5a  
ecx: 037478b8   edx: 00001000
Apr 21 10:08:14 rocks kernel: esi: 1510e290   edi: 00000000   ebp:
2ca47484   esp: 1bf99dd4
Apr 21 10:08:14 rocks kernel: ds: 007b   es: 007b   ss: 0068
Apr 21 10:08:14 rocks kernel: Process mv (pid: 10731,
threadinfo=1bf99000 task=36d7d340)
Apr 21 10:08:14 rocks kernel: Stack: 00001000 00002000 0d94a974
037478b8 037478b8 00000000 2ca47484 0d94a974
Apr 21 10:08:14 rocks kernel:        43ac8ba3 037478b8 00000000
00000000 2ca47540 02141920 00000000 00001000
Apr 21 10:08:14 rocks kernel:        00000000 2ca47484 00000000
02141b06 1bf99e68 1bf99f18 0d94a974 0d94a9bc
Apr 21 10:08:14 rocks kernel: Call Trace:
Apr 21 10:08:14 rocks kernel:  [<43ac8ba3>] nfs_readpage+0x7c/0x8e [nfs]
Apr 21 10:08:14 rocks kernel:  [<02141920>]
do_generic_mapping_read+0x31c/0x502
Apr 21 10:08:14 rocks kernel:  [<02141b06>] file_read_actor+0x0/0x101
Apr 21 10:08:14 rocks kernel:  [<02141d5e>]
__generic_file_aio_read+0x157/0x171
Apr 21 10:08:14 rocks kernel:  [<02141b06>] file_read_actor+0x0/0x101
Apr 21 10:08:14 rocks kernel:  [<02141db8>]
generic_file_aio_read+0x40/0x47
Apr 21 10:08:14 rocks kernel:  [<43ac2631>] nfs_file_read+0xb4/0xbe [nfs]
Apr 21 10:08:14 rocks kernel:  [<02163c2d>] do_sync_read+0x68/0x9d
Apr 21 10:08:14 rocks kernel:  [<021bdf9c>] inode_has_perm+0x57/0x5f
Apr 21 10:08:14 rocks kernel:  [<021bff17>]
selinux_file_permission+0x127/0x131
Apr 21 10:08:14 rocks kernel:  [<02163d1a>] vfs_read+0xb8/0xe4
Apr 21 10:08:14 rocks kernel:  [<02163ef3>] sys_read+0x2c/0x42
Apr 21 10:08:14 rocks kernel:
Apr 21 10:08:14 rocks kernel: Code: 0f 0b 3b 00 83 e1 ad 43 ba 17 00
00 00 89 c8 e8 84 4b 65 be


$ uname -a
Linux rocks 2.6.4-1.281 #1 Mon Mar 22 11:20:17 EST 2004 i686 athlon
i386 GNU/Linux

$ cat /etc/fedora-release
Fedora Core release 1.91 (FC2)
Comment 1 Dave Jones 2004-06-14 20:40:23 EDT
still occuring with the current errata kernel ?
Comment 2 Eugene Kanter 2004-08-31 22:49:23 EDT
I did a search on nfs hung and found this bug.
My problem seems to be similar but there are no oopses.
Two systems with latest fedora kernels. NFS server and client.
copy large file (>100 meg) may hang NFS client. It acts like there is
no network. Howver network between two systems is fine and I can scp
large files for as long as I want with no visible problems. The NFS
may or may not recover itself eventually if I ^C out of copy command.
I am attaching tcpdump -vv port nfs taken from NFS server box.
both kernels are 2.6.8-1.533. I remember that fedora core 2 working
with redhat 7.3 NFS server initially might have had no problems - I
did not noticed any. It possibly started when I updgraded NFS client
to Core 2 released updates. Since that I replaced all network cards
and switches between two systems and updated NFS server to latest
rawhide. It made no differences.
Comment 3 Eugene Kanter 2004-08-31 22:51:21 EDT
Created attachment 103325 [details]
output from "tcpdump -vv port nfs"
Comment 4 Dave Jones 2004-12-07 01:23:21 EST
how goes the 2.6.9 update kernel ? There were quite a number of nfs fixes going
into that one.
Comment 5 P Jones 2005-03-10 08:46:44 EST
I can't reproduce it now, so I guess the kernel change fixed it, or
the POM is wrong...

Note You need to log in before you can comment on or make changes to this bug.