Bug 121428 - gnome-font-properties segfautls when ran
gnome-font-properties segfautls when ran
Status: CLOSED DUPLICATE of bug 128727
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: control-center (Show other bugs)
3.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
David Lawrence
:
: 90616 (view as bug list)
Depends On: 128272
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-21 10:52 EDT by Jesse Keating
Modified: 2008-04-30 21:39 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-10 14:08:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2004-04-21 10:52:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
running gnome-font-properties causes segfault.  

(gdb) run
Starting program: /usr/bin/gnome-font-properties
[Thread debugging using libthread_db enabled]
[New Thread 182971056576 (LWP 2143)]
 
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 182971056576 (LWP 2143)]
0x0000002a982674c0 in g_closure_invoke () from
/usr/lib64/libgobject-2.0.so.0


Here is the backtrace:

(gdb) backtrace
#0  0x0000002a982674c0 in g_closure_invoke () from
/usr/lib64/libgobject-2.0.so.0
#1  0x0000002a98278118 in g_signal_emit_by_name () from
/usr/lib64/libgobject-2.0.so.0
#2  0x0000002a98276e2c in g_signal_emit_valist () from
/usr/lib64/libgobject-2.0.so.0
#3  0x0000002a982772d3 in g_signal_emit () from
/usr/lib64/libgobject-2.0.so.0
#4  0x0000002a97303d48 in gtk_widget_send_expose () from
/usr/lib64/libgtk-x11-2.0.so.0
#5  0x0000002a9723c18b in gtk_main_do_event () from
/usr/lib64/libgtk-x11-2.0.so.0
#6  0x0000002a9750d958 in gdk_window_clear_area_e () from
/usr/lib64/libgdk-x11-2.0.so.0
#7  0x0000002a9750da1d in gdk_window_process_all_updates () from
/usr/lib64/libgdk-x11-2.0.so.0
#8  0x0000002a9750da75 in gdk_window_process_all_updates () from
/usr/lib64/libgdk-x11-2.0.so.0
#9  0x0000002a9884cf6e in g_timeout_add () from
/usr/lib64/libglib-2.0.so.0
#10 0x0000002a9884a73f in unblock_source () from
/usr/lib64/libglib-2.0.so.0
#11 0x0000002a9884b64c in g_main_context_dispatch () from
/usr/lib64/libglib-2.0.so.0
#12 0x0000002a9884b914 in g_main_context_dispatch () from
/usr/lib64/libglib-2.0.so.0
#13 0x0000002a9884bf1d in g_main_loop_run () from
/usr/lib64/libglib-2.0.so.0
#14 0x0000002a9723bae0 in gtk_main () from /usr/lib64/libgtk-x11-2.0.so.0
#15 0x0000000000407ab9 in main (argc=1, argv=0x7fbffff8b8) at main.c:887


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. run gnome-font-properties on x86_64
    

Actual Results:  segfault

Expected Results:  The ability to manage my font rendering
Comment 1 Alan Cox 2004-05-02 19:59:19 EDT
Works for me in FC2 test3
Comment 3 Alexandre Oliva 2004-07-31 11:00:24 EDT
*** Bug 90616 has been marked as a duplicate of this bug. ***
Comment 4 Michael Napolis 2004-11-24 20:57:47 EST
I'm using RHEL3 U3 AMD64 machine.  Whenever I ran
gnome-font-properties it seg faults.  I have the latest gtk2 and
control-center available in RHN:

gtk2-2.2.4-8.1-x86_64
gtk2-2.2.4-8.1-i386
control-center-2.2.0.1-13-x86_64


Note You need to log in before you can comment on or make changes to this bug.