Bug 121431 - libaio rpm does not "provide" libaio.so.1
libaio rpm does not "provide" libaio.so.1
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libaio (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeffrey Moyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-21 11:00 EDT by Avi Kivity
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-11 16:10:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Avi Kivity 2004-04-21 11:00:23 EDT
Description of problem: 
 
libaio RPM does not "provide" libaio.so.1 (although the file is there). this 
prevents installation of packages which require it (e.g. lam) 
 
Version-Release number of selected component (if applicable): 
 
0.3.99-2 
 
How reproducible: 
 
 
Steps to Reproduce: 
1. rpm -q  --provides libaio 
   
Actual results: 
 
libaio.so.1.0.0 
libaio.so.1.0.0(LIBAIO_0.1) 
libaio.so.1.0.0(LIBAIO_0.4) 
libaio = 0.3.99-2 
 
 
Expected results: 
 
libaio.so.1 
libaio.so.1.0.0 
libaio.so.1.0.0(LIBAIO_0.1) 
libaio.so.1.0.0(LIBAIO_0.4) 
libaio = 0.3.99-2 
 
 
Additional info:
Comment 1 Jeffrey Moyer 2004-11-01 17:35:31 EST
This should work.  Can you please try this again and let me know if the problem
persists?  To be clear, I have been unable to reproduce this problem.
Comment 2 Avi Kivity 2004-11-02 03:58:59 EST
It doesn't reproduce because lam now requires libaio.so.1.0.0 instead
of libaio.so.1.

From my understanding of shared libraries, it is customary to provide
libblah.so, libblah.so.x, and libblah.so.x.y:

<main_snapfs-avi> [avi@baboon src]$ ls -l /usr/lib/libz.so*
lrwxrwxrwx    1 root     root           13 Jul  1  2003
/usr/lib/libz.so -> libz.so.1.1.4
lrwxrwxrwx    1 root     root           13 Jul  1  2003
/usr/lib/libz.so.1 -> libz.so.1.1.4
-rwxr-xr-x    1 root     root        53884 Feb 24  2003
/usr/lib/libz.so.1.1.4


however I am no expert in these matters.
Comment 3 Jeffrey Moyer 2004-12-21 10:26:42 EST
Please retest with the current versions of libaio and lam.  This issue should be
resolved.
Comment 4 Jeffrey Moyer 2005-04-11 16:10:37 EDT
This issue is fixed with libaio version 0.3.103.

Note You need to log in before you can comment on or make changes to this bug.