Bug 121450 - Bad text connection translation using ISO8859-1
Summary: Bad text connection translation using ISO8859-1
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: redhat-config-network   
(Show other bugs)
Version: 1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-21 17:45 UTC by Rubén
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version: 1.3.26-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-16 12:57:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rubén 2004-04-21 17:45:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; es-ES; rv:1.4.1)
Gecko/20031030

Description of problem:
Using ISO8859-1 and not UTF-8 (standard in Fedora) text displayed in
spanish when a user makes a modem connection is: "Activaci" instead of
the correct message: "Activación del dispositivo..."

Version-Release number of selected component (if applicable):
redhat-config-network-1.3.10-1

How reproducible:
Always

Steps to Reproduce:
1.Choose LC_CTYPE=ES_es.ISO8859-1
2. Launch redhat-config-network
3. Activate a modem connection
    

Additional info:

Comment 1 Harald Hoyer 2004-04-22 08:17:16 UTC
CTYPE??? why not LANG= ???

man setlocale

LC_CTYPE
   for regular expression matching, character classification,  con-
   version,  case-sensitive  comparison,  and  wide character func-
   tions.


Comment 2 Rubén 2004-04-22 16:58:43 UTC
In my system, if you only select LANG=es_ES or LANG=es_ES@euro or
LANG=es_ES.ISO8859-1 ... change is not reflected in locale.
You could then make:
> locale 
and could see that LANG=es_ES.UTF-8 

I tell you LC_CTYPE because is the real variable that affect that
message, i've been probed changing the others.

This happens with ISO8859-1 and also ISO8859-15. My actual
/etc/sysconfig/i18n is:
LANG="es_ES@euro"
SUPPORTED="en_US.UTF-8:en_US:en:es_ES.UTF-8:es_ES@euro:es_ES:es"
SYSFONT="latarcyrheb-sun16"
LC_ALL="es_ES@euro"

I set LC_ALL to change all variables to es_ES@euro (ISO8859-15),
because LANG=es_ES@euro doesn't work.
If you make locale in may system the exit is:
LANG=es_ES.UTF-8
LC_CTYPE="es_ES@euro"
LC_NUMERIC="es_ES@euro"
LC_TIME="es_ES@euro"
LC_COLLATE="es_ES@euro"
LC_MONETARY="es_ES@euro"
LC_MESSAGES="es_ES@euro"
LC_PAPER="es_ES@euro"
LC_NAME="es_ES@euro"
LC_ADDRESS="es_ES@euro"
LC_TELEPHONE="es_ES@euro"
LC_MEASUREMENT="es_ES@euro"
LC_IDENTIFICATION="es_ES@euro"
LC_ALL=es_ES@euro

I hope this helps.



Note You need to log in before you can comment on or make changes to this bug.