Bug 121469 - can't read surten mail maps anymore in evolution
can't read surten mail maps anymore in evolution
Status: CLOSED DUPLICATE of bug 121470
Product: Fedora
Classification: Fedora
Component: policy (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-21 16:38 EDT by lupus
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lupus 2004-04-21 16:38:53 EDT
Description of problem:
can't read surten mail maps anymore in evolution

gconf2 seems to be broken to. Maybe related!!

error message:

Fault when 'Opening map
file:///home/lupus/evolution/local/linux-hotplug-devel@lists.sourceforge.net
':
Summary
//home/lupus/evolution/local/linux-hotplug-devel@lists.sourceforge.net
/mbox not allowed: Access denied


dmesg:

audit(1082579661.917:0): avc:  denied  { unlink } for  pid=2089
exe=/usr/bin/evolution-1.4 name=mbox.ev-summary dev=hda3 ino=682132
scontext=user_u:user_r:user_t tcontext=system_u:object_r:file_t
tclass=file
audit(1082579661.963:0): avc:  denied  { unlink } for  pid=2089
exe=/usr/bin/evolution-1.4 name=mbox.ev-summary dev=hda3 ino=682132
scontext=user_u:user_r:user_t tcontext=system_u:object_r:file_t
tclass=file
audit(1082579662.058:0): avc:  denied  { append } for  pid=1903
exe=/usr/libexec/gconfd-2 name=saved_state dev=hda3 ino=681558
scontext=user_u:user_r:user_t tcontext=system_u:object_r:file_t
tclass=file
audit(1082579662.058:0): avc:  denied  { append } for  pid=1903
exe=/usr/libexec/gconfd-2 name=saved_state dev=hda3 ino=681558
scontext=user_u:user_r:user_t tcontext=system_u:object_r:file_t
tclass=file
audit(1082579662.090:0): avc:  denied  { getattr } for  pid=1903
exe=/usr/libexec/gconfd-2 path=/home/lupus/.gconfd/saved_state
dev=hda3 ino=681558 scontext=user_u:user_r:user_t
tcontext=system_u:object_r:file_t tclass=file
audit(1082579662.091:0): avc:  denied  { unlink } for  pid=1903
exe=/usr/libexec/gconfd-2 name=saved_state dev=hda3 ino=681558
scontext=user_u:user_r:user_t tcontext=system_u:object_r:file_t
tclass=file
audit(1082579662.710:0): avc:  denied  { getattr } for  pid=2089
exe=/usr/bin/evolution-1.4
path=/home/lupus/evolution/local/Inbox/mbox.ev-summary dev=hda3
ino=684105 scontext=user_u:user_r:user_t
tcontext=system_u:object_r:file_t tclass=file
audit(1082579662.826:0): avc:  denied  { unlink } for  pid=2089
exe=/usr/bin/evolution-1.4 name=mbox.ev-summary dev=hda3 ino=684105
scontext=user_u:user_r:user_t tcontext=system_u:object_r:file_t
tclass=file
audit(1082579662.832:0): avc:  denied  { unlink } for  pid=2089
exe=/usr/bin/evolution-1.4 name=mbox.ev-summary dev=hda3 ino=684105
scontext=user_u:user_r:user_t tcontext=system_u:object_r:file_t
tclass=file
audit(1082579662.966:0): avc:  denied  { getattr } for  pid=2089
exe=/usr/bin/evolution-1.4
path=/home/lupus/evolution/local/alsa-devel@lists.sourceforge.net
/mbox.ev-summary dev=hda3 ino=684108 scontext=user_u:user_r:user_t
tcontext=system_u:object_r:file_t tclass=file
audit(1082579663.564:0): avc:  denied  { unlink } for  pid=2089
exe=/usr/bin/evolution-1.4 name=mbox.ev-summary dev=hda3 ino=684108
scontext=user_u:user_r:user_t tcontext=system_u:object_r:file_t
tclass=file
audit(1082579663.569:0): avc:  denied  { unlink } for  pid=2089
exe=/usr/bin/evolution-1.4 name=mbox.ev-summary dev=hda3 ino=684108
scontext=user_u:user_r:user_t tcontext=system_u:object_r:file_t
tclass=file
audit(1082579663.712:0): avc:  denied  { getattr } for  pid=2089
exe=/usr/bin/evolution-1.4
path=/home/lupus/evolution/local/fedora-test-list@redhat.com/mbox.ev-summary
dev=hda3 ino=684103 scontext=user_u:user_r:user_t
tcontext=system_u:object_r:file_t tclass=file
audit(1082579664.365:0): avc:  denied  { unlink } for  pid=2089
exe=/usr/bin/evolution-1.4 name=mbox.ev-summary dev=hda3 ino=684103
scontext=user_u:user_r:user_t tcontext=system_u:object_r:file_t
tclass=file
audit(1082579664.556:0): avc:  denied  { unlink } for  pid=2089
exe=/usr/bin/evolution-1.4 name=mbox.ev-summary dev=hda3 ino=684103
scontext=user_u:user_r:user_t tcontext=system_u:object_r:file_t
tclass=file
audit(1082579664.809:0): avc:  denied  { getattr } for  pid=2089
exe=/usr/bin/evolution-1.4
path=/home/lupus/evolution/local/linux-hotplug-devel@lists.sourceforge.net
/mbox.ev-summary dev=hda3 ino=684109 scontext=user_u:user_r:user_t
tcontext=system_u:object_r:file_t tclass=file
audit(1082579664.874:0): avc:  denied  { unlink } for  pid=2089
exe=/usr/bin/evolution-1.4 name=mbox.ev-summary dev=hda3 ino=684109
scontext=user_u:user_r:user_t tcontext=system_u:object_r:file_t
tclass=file
audit(1082579664.879:0): avc:  denied  { unlink } for  pid=2089
exe=/usr/bin/evolution-1.4 name=mbox.ev-summary dev=hda3 ino=684109
scontext=user_u:user_r:user_t tcontext=system_u:object_r:file_t
tclass=file
audit(1082579664.901:0): avc:  denied  { getattr } for  pid=2089
exe=/usr/bin/evolution-1.4
path=/home/lupus/evolution/local/fedora-devel-list@redhat.com/mbox.ev-summary
dev=hda3 ino=682132 scontext=user_u:user_r:user_t
tcontext=system_u:object_r:file_t tclass=file
audit(1082579665.187:0): avc:  denied  { unlink } for  pid=2089
exe=/usr/bin/evolution-1.4 name=mbox.ev-summary dev=hda3 ino=682132
scontext=user_u:user_r:user_t tcontext=system_u:object_r:file_t
tclass=file
audit(1082579665.303:0): avc:  denied  { unlink } for  pid=2089
exe=/usr/bin/evolution-1.4 name=mbox.ev-summary dev=hda3 ino=682132
scontext=user_u:user_r:user_t tcontext=system_u:object_r:file_t
tclass=file
audit(1082579665.608:0): avc:  denied  { unlink } for  pid=1446
exe=/usr/sbin/cupsd name=0 dev=hda3 ino=389387
scontext=system_u:system_r:cupsd_t tcontext=system_u:object_r:file_t
tclass=file
audit(1082579666.319:0): avc:  denied  { getattr } for  pid=2089
exe=/usr/bin/evolution-1.4
path=/home/lupus/evolution/local/Inbox/mbox.ev-summary dev=hda3
ino=684105 scontext=user_u:user_r:user_t
tcontext=system_u:object_r:file_t tclass=file
audit(1082579666.431:0): avc:  denied  { unlink } for  pid=2089
exe=/usr/bin/evolution-1.4 name=mbox.ev-summary dev=hda3 ino=684105
scontext=user_u:user_r:user_t tcontext=system_u:object_r:file_t
tclass=file
audit(1082579666.437:0): avc:  denied  { unlink } for  pid=2089
exe=/usr/bin/evolution-1.4 name=mbox.ev-summary dev=hda3 ino=684105
scontext=user_u:user_r:user_t tcontext=system_u:object_r:file_t
tclass=file
audit(1082579666.459:0): avc:  denied  { getattr } for  pid=2089
exe=/usr/bin/evolution-1.4
path=/home/lupus/evolution/local/alsa-devel@lists.sourceforge.net
/mbox.ev-summary dev=hda3 ino=684108 scontext=user_u:user_r:user_t
tcontext=system_u:object_r:file_t tclass=file
audit(1082579666.547:0): avc:  denied  { unlink } for  pid=2089
exe=/usr/bin/evolution-1.4 name=mbox.ev-summary dev=hda3 ino=684108
scontext=user_u:user_r:user_t tcontext=system_u:object_r:file_t
tclass=file
audit(1082579666.552:0): avc:  denied  { unlink } for  pid=2089
exe=/usr/bin/evolution-1.4 name=mbox.ev-summary dev=hda3 ino=684108
scontext=user_u:user_r:user_t tcontext=system_u:object_r:file_t
tclass=file
audit(1082579669.254:0): avc:  denied  { getattr } for  pid=2083
exe=/usr/bin/evolution-1.4
path=/home/lupus/evolution/config/et-expanded-file:_home_lupus_evolution_local_xlibs@freedesktop.org
dev=hda3 ino=684096 scontext=user_u:user_r:user_t
tcontext=system_u:object_r:file_t tclass=file
audit(1082579670.579:0): avc:  denied  { unlink } for  pid=2083
exe=/usr/bin/evolution-1.4
name=et-expanded-file:_home_lupus_evolution_local_xlibs@freedesktop.org
dev=hda3 ino=684096 scontext=user_u:user_r:user_t
tcontext=system_u:object_r:file_t tclass=file
audit(1082579670.615:0): avc:  denied  { getattr } for  pid=2083
exe=/usr/bin/evolution-1.4
path=/home/lupus/evolution/views/mail/custom_view-file:_home_lupus_evolution_local_xdg@freedesktop.org_.xml
dev=hda3 ino=681840 scontext=user_u:user_r:user_t
tcontext=system_u:object_r:file_t tclass=file
audit(1082579670.615:0): avc:  denied  { getattr } for  pid=2083
exe=/usr/bin/evolution-1.4
path=/home/lupus/evolution/views/mail/custom_view-file:_home_lupus_evolution_local_xdg@freedesktop.org_.xml
dev=hda3 ino=681840 scontext=user_u:user_r:user_t
tcontext=system_u:object_r:file_t tclass=file
audit(1082579670.629:0): avc:  denied  { getattr } for  pid=2083
exe=/usr/bin/evolution-1.4
path=/home/lupus/evolution/views/mail/custom_view-file:_home_lupus_evolution_local_xdg@freedesktop.org_.xml
dev=hda3 ino=681840 scontext=user_u:user_r:user_t
tcontext=system_u:object_r:file_t tclass=file
audit(1082579670.629:0): avc:  denied  { getattr } for  pid=2083
exe=/usr/bin/evolution-1.4
path=/home/lupus/evolution/views/mail/custom_view-file:_home_lupus_evolution_local_xdg@freedesktop.org_.xml
dev=hda3 ino=681840 scontext=user_u:user_r:user_t
tcontext=system_u:object_r:file_t tclass=file
audit(1082579670.629:0): avc:  denied  { getattr } for  pid=2083
exe=/usr/bin/evolution-1.4
path=/home/lupus/evolution/views/mail/custom_view-file:_home_lupus_evolution_local_xdg@freedesktop.org_.xml
dev=hda3 ino=681840 scontext=user_u:user_r:user_t
tcontext=system_u:object_r:file_t tclass=file
audit(1082579670.629:0): avc:  denied  { getattr } for  pid=2083
exe=/usr/bin/evolution-1.4
path=/home/lupus/evolution/views/mail/custom_view-file:_home_lupus_evolution_local_xdg@freedesktop.org_.xml
dev=hda3 ino=681840 scontext=user_u:user_r:user_t
tcontext=system_u:object_r:file_t tclass=file
audit(1082579675.772:0): avc:  denied  { getattr } for  pid=2083
exe=/usr/bin/evolution-1.4
path=/home/lupus/evolution/config/et-expanded-file:_home_lupus_evolution_local_garnome-list@gnome.org
dev=hda3 ino=684100 scontext=user_u:user_r:user_t
tcontext=system_u:object_r:file_t tclass=file
audit(1082579677.415:0): avc:  denied  { unlink } for  pid=2083
exe=/usr/bin/evolution-1.4
name=et-expanded-file:_home_lupus_evolution_local_garnome-list@gnome.org
dev=hda3 ino=684100 scontext=user_u:user_r:user_t
tcontext=system_u:object_r:file_t tclass=file
audit(1082579677.505:0): avc:  denied  { unlink } for  pid=2083
exe=/usr/bin/evolution-1.4
name=et-expanded-file:_home_lupus_evolution_local_xlibs@freedesktop.org
dev=hda3 ino=684096 scontext=user_u:user_r:user_t
tcontext=system_u:object_r:file_t tclass=file
audit(1082579677.649:0): avc:  denied  { unlink } for  pid=2083
exe=/usr/bin/evolution-1.4 name=camel-cert.db dev=hda3 ino=681861
scontext=user_u:user_r:user_t tcontext=system_u:object_r:file_t
tclass=file


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 lupus 2004-04-21 16:46:44 EDT
forget versions:

policy-1.11.2-13
evolution-1.4.6-1
Comment 2 Colin Walters 2004-04-21 17:16:59 EDT
This looks to be the same issue as bug 121470.

*** This bug has been marked as a duplicate of 121470 ***
Comment 3 Daniel Walsh 2004-04-22 09:43:16 EDT
When you see file_t in a avc message, it usually indicate a file
system that was never labeled or running a file system that does not
support Extended Attributes.  Has your system been labeled?  What file
system is running on 

home/lupus/evolution/local/fedora-devel-list@redhat.com/
Comment 4 lupus 2004-04-22 09:57:19 EDT
it is fixed by relabeling 

Can't the upgrade tools do this them selfs? or warn people that they
should do it when using selinux. This way you get less bug reports ;) 
Comment 5 Red Hat Bugzilla 2006-02-21 14:02:43 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.