Bug 12148 - graphical installer -> Xfree configuration, default modelines aren't always good enough
graphical installer -> Xfree configuration, default modelines aren't always g...
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-12 15:03 EDT by Hans de Goede
Modified: 2007-04-18 12:27 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-05 06:22:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2000-06-12 15:03:31 EDT
Hi the builtin modelines of XFree40 aren't always good enough I had to add
a modeline to get 1152x864 in 16 bpp  on my Matrox Millenium 1 for example,
so I think it would be wise to add modelines to the generated config, then
again the current setup results in a very readable config and the builtin
modelines are probavly very well tested.
Comment 1 Glen Foster 2000-07-18 14:35:41 EDT
This defect is considered MUST-FIX for Winston Beta-5
Comment 2 Glen Foster 2000-07-21 14:39:00 EDT
Does this defect still exist with (on) Winston beta-4?
Comment 3 Hans de Goede 2000-07-24 18:06:55 EDT
Well there are still no modelines in the generated XF86Config, so unless the
matrox driver changed significantly I think I still cannot get 1152x864 with
XF40 this way.

I'll check tomorrow when I upgrade the relevant machine to beta4.
Comment 4 Bill Nottingham 2000-07-24 18:37:27 EDT
Since we generate a working X config for this card, I'm switching
this to an enhancement request.
Comment 5 Michael Fulbright 2000-09-15 15:25:37 EDT
Assigning to Xconfigurator, as it is being rewritten and will solve many of
these problems.
Comment 6 Trond Eivind Glomsrxd 2000-09-26 17:59:42 EDT
Exactly what do your added modeline do? Higher frequency? Lower?
Comment 7 Hans de Goede 2000-10-04 14:47:13 EDT
Ehm, I dunno.

All I knew is I couldn't get 1152 x 864 x 16 bpp with my matrox millenium I 2
mb, and a NEC 4 Fge as monitor. Just adding the modelines from my XFree336
XF86Config fixed the problem.
Comment 8 Trond Eivind Glomsrxd 2000-10-04 14:50:15 EDT
What frequency does that result in?
Comment 9 Hans de Goede 2000-10-04 15:04:05 EDT
Ehm,

I currently have another card in but I'm still using the same modeline.

Here's the xvidtune info:
Pixel Clock: 92.00 Mhz
Hsync:       62.41 Khz
Vsync:       69.74 Khz

Comment 10 Trond Eivind Glomsrxd 2000-10-04 15:10:18 EDT
OK, I can see why X didn't want to use that as it's below 72 Hz and I'm guessing
it won't suggest a modeline for a bad/lowfrequency mode. How does it fail
without it?
Comment 11 Hans de Goede 2000-10-05 06:22:44 EDT
Depends, if almost always do a custom X setup in anaconda, normally O only check
the mode I want, then testing X just fails, if I check 1024x768 too, I get that
instead.

I didn't remember my mode was below the 72 Hz (My card can handle that but not
my monitor),
not allowing modes below 72Hz by defaults sounds sane to me.

So as far as I'm concerned this bug can be closed with notabug.

Note You need to log in before you can comment on or make changes to this bug.