Bug 121497 - Remove unnecessary carriage returns
Remove unnecessary carriage returns
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-22 00:57 EDT by Mike MacCana
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-26 14:50:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike MacCana 2004-04-22 00:57:39 EDT
Description of problem:
up2date's output puts carriage returns after every other line of
output. This bloats the output by about a half.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Run up2date to update the system or install a significant number of
packages
  
Actual results:
A large amount of output with a lot of blank lines. This means it
takes longer to read or scroll the output. It's also unlike other Unix
commands.

Eg:

Fetching package list for channel: fedora-1...
 
Fetching package list for channel: fedora-1-updates...
 
Fetching package list for channel: fedora-1-extras...
 
Fetching Obsoletes list for channel: fedora-1...
 
Fetching Obsoletes list for channel: fedora-1-updates...
 
Fetching Obsoletes list for channel: fedora-1-extras...
 
Fetching rpm headers...
 
Name                                    Version        Rel
----------------------------------------------------------
clamav                                  0.67           1             
     i386
firefox                                 0.8            0.rhfc1.dag   
     i386
sagator                                 20031230       1             
     i386
sagator-libclamav                       20031230       1             
     i386
 
 
Testing package set / solving RPM inter-dependencies...
Retrieved.
Retrieved.
Retrieved.
Retrieved.
Preparing
Installing /var/spool/up2date/sagator-libclamav-20031230-1.i386.rpm...
 
Installing /var/spool/up2date/clamav-0.67-1.i386.rpm...
 
Installing /var/spool/up2date/firefox-0.8-0.rhfc1.dag.i386.rpm...
 
Installing /var/spool/up2date/sagator-20031230-1.i386.rpm...


Expected results:
Less unnecessary line breaks:

Fetching package list for channel: fedora-1...
Fetching package list for channel: fedora-1-updates...
Fetching package list for channel: fedora-1-extras...

Fetching Obsoletes list for channel: fedora-1...
Fetching Obsoletes list for channel: fedora-1-updates...
Fetching Obsoletes list for channel: fedora-1-extras...

Fetching rpm headers...
Name                                    Version        Rel
----------------------------------------------------------
clamav                                  0.67           1             
     i386
firefox                                 0.8            0.rhfc1.dag   
     i386
sagator                                 20031230       1             
     i386
sagator-libclamav                       20031230       1             
     i386
 
 
Testing package set / solving RPM inter-dependencies...
Retrieved.
Retrieved.
Retrieved.
Retrieved.
Preparing

Installing /var/spool/up2date/sagator-libclamav-20031230-1.i386.rpm...
Installing /var/spool/up2date/clamav-0.67-1.i386.rpm...
Installing /var/spool/up2date/firefox-0.8-0.rhfc1.dag.i386.rpm...
Installing /var/spool/up2date/sagator-20031230-1.i386.rpm...

Additional info:
Comment 1 Suzanne Hillman 2004-04-23 11:13:08 EDT
Um. What product is this for? You said RHEL, but the bug appears to be
referencing fedora-1. Did you mean to select Fedora Core for the product?
Comment 2 Mike MacCana 2004-04-24 02:25:49 EDT
It applies to both. Sorry about any confusion, noticed the behavior 
on RHEL and then used an example from Fedora in this report.
Comment 3 Suzanne Hillman 2004-04-29 10:18:31 EDT
OK. So, then, RHEL2.1? RHEL3? Both?
Comment 4 Mike MacCana 2004-05-26 01:47:17 EDT
All up2dates since release. EL3, EL2.1, Fedora, etc.

Note You need to log in before you can comment on or make changes to this bug.