Bug 121534 - amd64 builds of wxWindows cause metacity to crash
amd64 builds of wxWindows cause metacity to crash
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
1
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-22 11:09 EDT by Bryan Cole
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-03 13:36:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan Cole 2004-04-22 11:09:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686) Gecko/20040323 Galeon/1.3.7

Description of problem:
various components from wxGTK (www.wxWidgets.org), which is a fairly
thin wrapper around GTK or GTK2, cause metacity to crash. This occurs
when wxGTK is built on fedoraCore1-(64-bit). wxGTK runs fine on 32-bit
FC1. 

Note the crash even occurs over a networked X connection: i.e. with
wxGTK apps running on a x86_64 system and displayed on a remote X
terminal running 32-bit RH9, metacity crashes *on the 32-bit RH9 system*!

When metacity creashes, the wxGTK app continues running (but the
window display is messed up: no window boarders, or virtual desktops etc.)

Note, if wxGTK is run within a KDE envirnoment (32-bit remote or
64-bit local), everything appears fine. The situation is the same for
wxGTK built for both GTK-1.2 and GTK-2.2

I don't really know if this is a bug in X11, metacity, GTK+ or wxGTK.
Since I get the same behavious for both gtk-1.2 & gtk-2.2 but the
problem goes away with a different window manager, I suspect it's a
metacity thing (present in all versions, 32 or 64bit).


Version-Release number of selected component (if applicable):
metacity 2.6.3 & 2.4.55

How reproducible:
Always

Steps to Reproduce:
1. build wxGTK on a FedoraCore1 64-bit system 
2. run a selection of the "samples"
3. watch metacity crash out...
    

Actual Results:  metacity died

Expected Results:  metacity should not have died!

Additional info:
Comment 1 Havoc Pennington 2004-05-25 12:19:21 EDT
Has anyone tested this on FC2?
Comment 2 Havoc Pennington 2004-05-25 16:34:13 EDT
Reopen if still present in FC2.

Note You need to log in before you can comment on or make changes to this bug.