Bug 121541 - (ACPI)Network Routing Failure - Toshiba SatPro4600
(ACPI)Network Routing Failure - Toshiba SatPro4600
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-22 12:44 EDT by Angus Carr
Modified: 2015-01-04 17:05 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-07 01:23:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ran lspci, cat /proc/pci, route -n, ifconfig eth0, dmesg (19.83 KB, text/plain)
2004-04-23 01:54 EDT, Angus Carr
no flags Details
acpidmp output with kernel parameter acpi=on (110.28 KB, text/plain)
2004-05-20 15:31 EDT, Angus Carr
no flags Details
acpidmp output with kernel parameter acpi=off (110.28 KB, text/plain)
2004-05-20 15:32 EDT, Angus Carr
no flags Details

  None (edit)
Description Angus Carr 2004-04-22 12:44:17 EDT
Description of problem:
On install of a FC2-test2 system, networking will not work.
The machine is known to work, as it has recently had FC1 on it, and
boots successfully to an LTSP server through PXE booting.

Computer is a Toshiba Satellite Pro 4600.

After booting the fresh install, the computer gets a DHCP address, but
is unable to route to the gateway box which provided the address.

route -n reports an apparently OK routing table, but ping reports host
unreachable.

The same things happen after changing to a static network address.

I have a FC1 machine handy for comparison, and the routing table seems
identical.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install FC2test2 (Personal Workstation, no other unique options)
2. Boot
3. ping or konqueror
    

Actual Results:  Host unreachable.

Expected Results:  ping return or web page of gateway.

Additional info:
Comment 1 Dave Jones 2004-04-22 13:00:55 EDT
does it work if you echo 0 > /proc/sys/net/ipv4/tcp_ecn   ?
Comment 2 Angus Carr 2004-04-23 01:21:37 EDT
No.
I am setting up a serial console to grab whatever files or  listings
would be useful to debug.

I will attach in a tgz file the /proc/pci listing, the lsmod listing,
route -n.  Anything else?

Comment 3 Angus Carr 2004-04-23 01:54:41 EDT
Created attachment 99645 [details]
ran lspci, cat /proc/pci, route -n, ifconfig eth0, dmesg
Comment 4 Alan Cox 2004-05-02 19:53:15 EDT
Your machine seems to have serious ACPI problems with the kernel. Try
running with the boot option "acpi=off" and report back if that fixes it.


Comment 5 Len Brown 2004-05-19 18:25:03 EDT
ACPI-0165: *** Error: No object was returned from [\_SB_.LNKA._STA] (Node 
11f5eea0), AE_NOT_EXIST 
... 
ACPI: No IRQ known for interrupt pin D of device 0000:00:1f.2 
... 
irq 11: nobody cared! (screaming interrupt?) 
... 
Oh yes, ACPI interrupt configuration is very broken here. 
/proc/interrupts may show your devices on the wrong irqs. 
"pci=noacpi" would probably be a sufficient workaround. 
 
Please verify that you're running the latest BIOS 
Please verify that if there are any ACPI related settings in SETUP 
that ACPI is enabled. 
Please attach the output from acpidmp available in /usr/sbin/, or in pmtools: 
http://ftp.kernel.org/pub/linux/kernel/people/lenb/acpi/utils/ 
 
Probably good to update to the final FC2 release from test2. 
Also, it would be interesting if you can boot the latest 2.6 kernel.org kernel 
on this system, since it contains additional debugging info. 
 
Comment 6 Angus Carr 2004-05-20 13:12:40 EDT
BIOS Version 2.60, 10/12/2001, which is the latest one, according to
toshiba. URL of BIOS release notes:

http://209.167.114.38/support/Download/readme/bios/sp4600.htm

BIOS options set (reading them from the Windows program supplied by
Toshiba):
"Device Configureation": All Devices (not "Setup by OS")
Hardware Alarms: All on (Low Battery, Panel Close, System Beep)
LAN: Wake on LAN Enabled
USB Legacy Emulation: Disabled
CPU: Frequency Dynamically Switchable (not Always Hi or Always Low)

Anyway, FWIW, I will try turning Wake on LAN off, then turning ACPI on
(removing kernel cmdline parameter), and see what that does. It's
always worth a try...
.......Time Passes........
Nope - still no network.

I will return to acpi=off, as suggested by Alan Cox. I will update the
system to the newly released final version of FC2, but I am not
hopeful. By the way, that did enable the network, so all was well for
a while.

In the mean time, I have re-enabled Wake On LAN, which (I think) is an
ACPI option, so that implies ACPI is running, but then I could also be
wrong. 

I will play, and see what I can arrange. Thank you all for your time
so far.
Comment 7 Angus Carr 2004-05-20 15:31:17 EDT
Created attachment 100387 [details]
acpidmp output with kernel parameter acpi=on

Ran acpidmp, downloaded and compiled from kernel.org. 
command line was
acpidmp > acpi_on_aspidmp.txt

And, no, I can't spell.... Yeesh.
Comment 8 Angus Carr 2004-05-20 15:32:30 EDT
Created attachment 100388 [details]
acpidmp output with kernel parameter acpi=off
Comment 9 shaohua li 2004-05-21 04:23:51 EDT
Sounds like no return value of '_STA' problem, please check the patch 
in http://bugme.osdl.org/show_bug.cgi?id=1729
Comment 10 Angus Carr 2004-05-21 10:58:11 EDT
Once my (overnight, HTTP) install of FC2final is complete, I will test
this patch. I agree that it sounds familiar. The bug referred to from
that bug is back here, on a Toshiba Tecra 8000.

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=107458

It certainly has the same message, although the specific behaviour is
different.
Comment 11 Len Brown 2004-05-22 01:02:02 EDT
disassembling the DSDT and re-compiling it gave 40 errors 
 
DSDT.dsl    55:             Method (_STA, 0, NotSerialized) 
Warning  2026 -                        ^ Reserved method must return a value (_STA) 
 
Depending on where these errors are in the source, 
the symptoms are different from system to system. 
 
Comment 12 Angus Carr 2004-05-25 11:30:05 EDT
Woohoo! I have now got a custom kernel with the patch referred to in
bug 107458 (see above). The kernel is stock FC2 (2.6.5-1.358) with the
 ACPI patch.

This is the patch in question:
https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=95284&action=view

I presently have a kernel booting with a command line "acpi=on" and
using the network, which solves my issues.

Thanks for all the help, everybody. I appreciate it, from the quick
workaround to the root cause fix, and especially the bug-identifying help.

It's a BIOS bug, but can we work around it permanently? Please? I
don't want to do a custom kernel every time I install FC on these
machines I have here.
Comment 13 Len Brown 2004-05-29 01:00:06 EDT
exactly what patch did you apply? 
bug 107458 doesn't contain a patch, 
and the url above is an acpidmp output file. 
 
did you try the patch on OSDL?: 
http://bugme.osdl.org/show_bug.cgi?id=1729 
Comment 14 Angus Carr 2004-05-31 02:01:24 EDT
MMMhmmm. Yes, it was the patch on OSDL, as you've noted. My mistake.
Comment 15 Dave Jones 2004-06-14 20:43:09 EDT
fixed in the current errata kernel ?
Comment 16 Dave Jones 2004-12-07 01:23:55 EST
no response in 6 months - closing.

Note You need to log in before you can comment on or make changes to this bug.