Bug 121561 - gdb stops on scrolling to end-of-page.
gdb stops on scrolling to end-of-page.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gdb (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jan Kratochvil
:
: 147880 (view as bug list)
Depends On: 104517
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-22 20:10 EDT by David Woodhouse
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version: gdb-6.3.0.0-1.122
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-15 15:56:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2004-04-22 20:10:49 EDT
Description of problem:
The first time GDB reaches the end of a page, and prints its 'Type
<return> to continue...' prompt, it appears to receive SIGTTOU and stop.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:

lapdancer /home/dwmw2 # gdb /usr/sbin/prelink
GNU gdb Red Hat Linux (6.0post-0.20040223.8rh)
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and
you are
welcome to change it and/or distribute copies of it under certain
conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for
details.
This GDB was configured as "i386-redhat-linux-gnu"...(no debugging
symbols found)...Using host libthread_db library
"/lib/tls/libthread_db.so.1".
 
(gdb) set args -av
(gdb) run
Starting program: /usr/sbin/prelink -av
warning: shared library handler failed to enable breakpoint
Detaching after fork from child process 2061.
Detaching after fork from child process 2062.
Detaching after fork from child process 2063.
Detaching after fork from child process 2064.
Detaching after fork from child process 2065.
Detaching after fork from child process 2066.
Detaching after fork from child process 2067.
Detaching after fork from child process 2068.
Detaching after fork from child process 2069.
Detaching after fork from child process 2070.
Detaching after fork from child process 2071.
Detaching after fork from child process 2072.
Detaching after fork from child process 2073.
Detaching after fork from child process 2074.
Detaching after fork from child process 2075.
Detaching after fork from child process 2076.
Detaching after fork from child process 2077.
Detaching after fork from child process 2078.
Detaching after fork from child process 2079.
Detaching after fork from child process 2080.
Detaching after fork from child process 2081.
Detaching after fork from child process 2082.
 
[1]+  Stopped                 gdb /usr/sbin/prelink
lapdancer /home/dwmw2 # fg
gdb /usr/sbin/prelink
---Type <return> to continue, or q <return> to quit---

Expected results:

Much the same as the above but without having to type 'fg' to get back
to gdb.
Comment 2 Jan Kratochvil 2006-08-08 17:35:19 EDT
Suggesting to close - CURRENTRELEASE as at least gdb-6.3.0.0-1.122 (FC5) has it
fixed.

symfile.c:      printf_unfiltered ("Reading symbols from %s...", name);

(it was printf_filtered() before)
Comment 3 Jan Kratochvil 2007-03-24 12:46:51 EDT
*** Bug 147880 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.