Bug 12157 - Fujitsu Wide Ultra SCSI 3 drives fail
Fujitsu Wide Ultra SCSI 3 drives fail
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Doug Ledford
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-12 16:10 EDT by Milt Clauser
Modified: 2007-04-18 12:27 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-12 13:20:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milt Clauser 2000-06-12 16:10:04 EDT
I have a Compaq SP750 with an Adaptec AIC-7899 SCSI adapter and Fujitsu 
hard drives, specifically 9.1 and 18.2 GB 10000 rpm wide ultra SCSI 3 
drives.  (The drives were supplied by Compaq under Compaq part numbers. The 
drives work fine with Windows NT and 2000.)  When I try to install Red Hat 
Linux 6.2, the installation hangs while trying to load the AIC7XXX SCSI 
driver.  I tried using the v 5.1.30 update for aic7xxx and that did not fix 
the problem.  When I replace the Fujitsu drive with a Quantum drive, I am 
able to install Linux with no problem.  (Hence the Fujitsu drive appears to 
be the culprit.)  When I put the Fujitsu drive back in the computer as a 
second drive, in addition to the Quantum drive, Linux won't boot; I get the 
error message:

Parity error during Message-Out phase

followed by infinitely repeated lines of:

scsi: aborting command due to timeout: pid 3, scsi 0, channel 0, id 2, lun 
0 Test Unit Ready 00 00 00 00 00
Comment 1 Need Real Name 2000-09-04 17:28:59 EDT
Seeing the same problem with Seagate ST39204LC Ultra 3 10k LVD drives.  Intel 
ISP 2150 is caught in infinite loop when trying to install SCSI driver.  Tried 
to set the drive to single-ended mode, no luck.  IBM SE drives work great. 
Controller is on-board AIC-7896.
Comment 2 Doug Ledford 2000-10-26 16:41:54 EDT
Try disabling drive initiated speed negotiation messages (there is usually a
jumper on the drive itself that does this, often times labeled SDTR or Targ Init
SDTR or something like that).  Doing that should likely solve your problem.  The
next possible solution is to go into the SCSI BIOS on the controller and limit
the speed of the drive to 80MB/s.
Comment 3 Perry Harrington 2000-12-10 01:52:49 EST
I have an ISP 2150 with 4 36GB Cheetahs, and it works killer:

(scsi0) Downloading sequencer code... 392 instructions downloaded
(scsi1) <Adaptec AIC-7896/7 Ultra2 SCSI host adapter> found at PCI 0/12/1
(scsi1) Wide Channel B, SCSI ID=7, 32/255 SCBs
(scsi1) Downloading sequencer code... 392 instructions downloaded
scsi0 : Adaptec AHA274x/284x/294x (EISA/VLB/PCI-Fast SCSI) 5.1.31/3.2.4
       <Adaptec AIC-7896/7 Ultra2 SCSI host adapter>
scsi1 : Adaptec AHA274x/284x/294x (EISA/VLB/PCI-Fast SCSI) 5.1.31/3.2.4
       <Adaptec AIC-7896/7 Ultra2 SCSI host adapter>
scsi : 2 hosts.
(scsi0:0:0:0) Synchronous at 80.0 Mbyte/sec, offset 63.
  Vendor: SEAGATE   Model: ST336704LC        Rev: 0003
  Type:   Direct-Access                      ANSI SCSI revision: 03
Detected scsi disk sda at scsi0, channel 0, id 0, lun 0
(scsi0:0:1:0) Synchronous at 80.0 Mbyte/sec, offset 63.
  Vendor: SEAGATE   Model: ST336704LC        Rev: 0003
  Type:   Direct-Access                      ANSI SCSI revision: 03
Detected scsi disk sdb at scsi0, channel 0, id 1, lun 0
(scsi0:0:2:0) Synchronous at 80.0 Mbyte/sec, offset 63.
  Vendor: SEAGATE   Model: ST336704LC        Rev: 0003
  Type:   Direct-Access                      ANSI SCSI revision: 03
Detected scsi disk sdc at scsi0, channel 0, id 2, lun 0
(scsi0:0:3:0) Synchronous at 80.0 Mbyte/sec, offset 63.
  Vendor: SEAGATE   Model: ST336704LC        Rev: 0003
  Type:   Direct-Access                      ANSI SCSI revision: 03
Detected scsi disk sdd at scsi0, channel 0, id 3, lun 0
  Vendor: ESG-SHV   Model: SCA HSBP M10      Rev: 0.03
  Type:   Processor                          ANSI SCSI revision: 02

My guess is that the HDDs you have need a firmware update.
Comment 4 James Davis 2004-04-26 06:38:30 EDT
I have exactly the same symptoms with an ISP 2150 and a Seagate
ST318436LC drive. Have tried two units of the same drive and problem
still occurs.
Comment 5 Doug Ledford 2004-05-12 13:20:33 EDT
This is an exceptionally old bug against a product that's no longer
around anywhere that I know of.  I'm closing this out.

Note You need to log in before you can comment on or make changes to this bug.