Bug 121596 - mozilla -> ps2pdf files do not display properly in xpdf
mozilla -> ps2pdf files do not display properly in xpdf
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xpdf (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Mike McLean
http://bugzilla.mozilla.org/show_bug....
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-23 13:52 EDT by Andrew Schultz
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-24 12:12:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
postscript printout of this bug page (230.22 KB, application/postscript)
2004-07-14 19:57 EDT, Andrew Schultz
no flags Details
pdf file generated by ps2pdf on the previous attachment (30.79 KB, application/pdf)
2004-07-14 20:01 EDT, Andrew Schultz
no flags Details

  None (edit)
Description Andrew Schultz 2004-04-23 13:52:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a)
Gecko/20040422

Description of problem:
A pdf file generated by printing from Mozilla and then running ps2pdf
cannot be displayed properly in xpdf.  No text shows up, although
images do.  In the terminal, I get:

Error (1891): No font in show
Error (1908): No font in move/show
Error: Unknown font tag 'R14'


Version-Release number of selected component (if applicable):
xpdf-3.00-3

How reproducible:
Always

Steps to Reproduce:
1. make a postscript file from Mozilla (file->print)
2. convert file to pdf with ps2pdf
3. load pdf in xpdf

Actual Results:  no text

Expected Results:  text

Additional info:
I'm using ghostscript 7.07-25 (Fedora-devel).  The same happened with
FC1's ghostscript, and xpdf.  I'm testing with Mozilla trunk/gtk1 (no
xft), but the same happens with an xft Mozilla build.
Comment 1 Ngo Than 2004-06-24 12:12:55 EDT
could you please give me a testcase, which causes this problem please?

i went to http://bugzilla.mozilla.org/show_bug.cgi?id=241295 and tried 
to print this page and converted it into pdf with ps2pdf afterward. 

xpdf can show this new converted pdf file without any problem. It
works for me!

please reopen it again if you have better testcase for reproducing
this problem. Thanks
Comment 2 Andrew Schultz 2004-07-14 19:57:57 EDT
Created attachment 101924 [details]
postscript printout of this bug page

this looks fine with gs-7.07-25
Comment 3 Andrew Schultz 2004-07-14 20:01:59 EDT
Created attachment 101925 [details]
pdf file generated by ps2pdf on the previous attachment

this pdf has no text when viewed with xpdf-3.00-3
Comment 4 Andrew Schultz 2004-07-14 20:04:33 EDT
reopening

Note You need to log in before you can comment on or make changes to this bug.