Bug 121641 - xinetd cannot start rsync due to "bind failed"
xinetd cannot start rsync due to "bind failed"
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rsync (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Fenlason
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-24 08:29 EDT by Thomas J. Baker
Modified: 2014-08-31 19:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-11 21:42:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas J. Baker 2004-04-24 08:29:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040312 Galeon/1.3.14

Description of problem:
I'm running with selinux turned off. When I start xinetd, I get this
in the logs:

Apr 24 08:19:55 wintermute xinetd: xinetd startup succeeded
Apr 24 08:19:55 wintermute xinetd[3980]: bind failed (Address already
in use (errno = 98)). service = rsync
Apr 24 08:19:55 wintermute xinetd[3980]: Service rsync failed to start
and is deactivated.
Apr 24 08:19:56 wintermute xinetd[3980]: xinetd Version 2.3.13 started
with libwrap loadavg options compiled in.
Apr 24 08:19:56 wintermute xinetd[3980]: Started working: 4 available
services

rsync is not already running. The rsync package hasn't changed since
April 7th and xinetd hasn't since March 1st so this may be kernel related.

Version-Release number of selected component (if applicable):
kernel-smp-2.6.5-1.339, rsync-2.6.1-0.pre1

How reproducible:
Always

Steps to Reproduce:
1. enable rsync
2. restart xinetd
3.
    

Actual Results:  xinetd complains that the rsync address is already is use

Expected Results:  it starts normally

Additional info:
Comment 1 Thomas J. Baker 2004-05-11 21:42:56 EDT
This has since gone away. I don't know if it was a kernel thing or
what but it doesn't happen with the 35x kernels.

Note You need to log in before you can comment on or make changes to this bug.