Bug 121643 - (VM) page allocation failure from dst_output
(VM) page allocation failure from dst_output
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-24 08:54 EDT by Neal Becker
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-14 20:45:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kernel freezes with page allocation errors (10.81 KB, text/plain)
2004-04-29 12:18 EDT, Tom London
no flags Details

  None (edit)
Description Neal Becker 2004-04-24 08:54:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux) (KHTML, like Gecko)

Description of problem:
Apr 24 05:38:06 localhost kernel: privoxy: page allocation failure. order:1, mode:0x20
Apr 24 05:38:06 localhost kernel: 
Apr 24 05:38:06 localhost kernel: Call Trace:<ffffffff80162de8>{__alloc_pages+780} <ffffffff80162e18>{__get_free_pages+31} 
Apr 24 05:38:06 localhost kernel:        <ffffffff80166dd1>{cache_grow+446} <ffffffff801673c4>{cache_alloc_refill+624} 
Apr 24 05:38:06 localhost kernel:        <ffffffff801677c2>{__kmalloc+79} <ffffffff802bfaef>{alloc_skb+64} 
Apr 24 05:38:06 localhost kernel:        <ffffffff802e4f56>{dst_output+0} <ffffffff802c017c>{skb_copy+42} 
Apr 24 05:38:06 localhost kernel:        <ffffffff802ce72e>{skb_ip_make_writable+206} <ffffffff802e4f56>{dst_output+0} 
Apr 24 05:38:06 localhost kernel:        <ffffffff802ce166>{nf_hook_slow+93} <ffffffff802e333c>{ip_queue_xmit+1118} 
Apr 24 05:38:06 localhost kernel:        <ffffffff802e4f56>{dst_output+0} <ffffffff802ee083>{tcp_ack_saw_tstamp+22} 
Apr 24 05:38:06 localhost kernel:        <ffffffff802ee276>{tcp_clean_rtx_queue+391} <ffffffff802f23ce>{tcp_transmit_skb+1318} 
Apr 24 05:38:06 localhost kernel:        <ffffffff802f30b1>{tcp_write_xmit+232} <ffffffff802e9628>{tcp_sendmsg+3891} 
Apr 24 05:38:06 localhost kernel:        <ffffffff80307e8f>{inet_sendmsg+70} <ffffffff802bc77d>{sock_aio_write+232} 
Apr 24 05:38:06 localhost kernel:        <ffffffff8018456e>{do_sync_write+102} <ffffffff801e9eb7>{avc_has_perm+69} 
Apr 24 05:38:06 localhost kernel:        <ffffffff801ed857>{selinux_file_permission+271} <ffffffff8018467d>{vfs_write+227} 
Apr 24 05:38:06 localhost kernel:        <ffffffff8018472e>{sys_write+57} <ffffffff80111ef2>{system_call+126} 
Apr 24 05:38:06 localhost kernel:        
Apr 24 05:38:06 localhost kernel: privoxy: page allocation failure. order:1, mode:0x20
Apr 24 05:38:06 localhost kernel: 
Apr 24 05:38:06 localhost kernel: Call Trace:<ffffffff80162de8>{__alloc_pages+780} <ffffffff80162e18>{__get_free_pages+31} 
Apr 24 05:38:06 localhost kernel:        <ffffffff80166dd1>{cache_grow+446} <ffffffff801673c4>{cache_alloc_refill+624} 
Apr 24 05:38:06 localhost kernel:        <ffffffff801677c2>{__kmalloc+79} <ffffffff802bfaef>{alloc_skb+64} 
Apr 24 05:38:06 localhost kernel:        <ffffffff802e4f56>{dst_output+0} <ffffffff802c017c>{skb_copy+42} 
Apr 24 05:38:06 localhost kernel:        <ffffffff802ce72e>{skb_ip_make_writable+206} <ffffffff802ee276>{tcp_clean_rtx_queue+391} 
Apr 24 05:38:06 localhost kernel:        <ffffffff802ce166>{nf_hook_slow+93} <ffffffff802e333c>{ip_queue_xmit+1118} 
Apr 24 05:38:06 localhost kernel:        <ffffffff802e9712>{tcp_sendmsg+4125} <ffffffff802f23ce>{tcp_transmit_skb+1318} 
Apr 24 05:38:06 localhost kernel:        <ffffffff802f30b1>{tcp_write_xmit+232} <ffffffff802f4009>{tcp_send_fin+448} 
Apr 24 05:38:06 localhost kernel:        <ffffffff802ea9e3>{tcp_close+558} <ffffffff8030785e>{inet_release+81} 
Apr 24 05:38:06 localhost kernel:        <ffffffff802bc3bd>{sock_release+23} <ffffffff802bcda0>{sock_close+44} 
Apr 24 05:38:06 localhost kernel:        <ffffffff80185450>{__fput+78} <ffffffff80183b37>{filp_close+105} 
Apr 24 05:38:06 localhost kernel:        <ffffffff80183ca0>{sys_close+354} <ffffffff80111ef2>{system_call+126} 
[... lots more ...]

Version-Release number of selected component (if applicable):
2.6.4-1.305

How reproducible:
Didn't try

Steps to Reproduce:
1.Probably happened while running updatedb
2.
3.
    

Additional info:
Comment 1 Tom London 2004-04-27 12:03:08 EDT
Not sure if this is the same, but I get this:

Apr 27 08:44:55 fedora kernel: swapper: page allocation failure.
order:1, mode:0x20
Apr 27 08:44:55 fedora kernel: Call Trace:
Apr 27 08:44:55 fedora kernel:  [<0213fbd3>] __alloc_pages+0x277/0x284
Apr 27 08:44:55 fedora kernel:  [<0213fbf8>] __get_free_pages+0x18/0x24
Apr 27 08:44:55 fedora kernel:  [<02143be5>] cache_grow+0x16b/0x3e0

on i686.  I also believe it has something to do with updatedb.....

I'm running kernel-2.6.5-1.332

Comment 2 Thomas Molina 2004-04-29 05:40:04 EDT
It is more likely to be the kernel.  I am getting the same page
allocation failure happening today.  I got a whole string of the same
trace in my logs between 0404 and 0436 this morning for fetchmail,
swapper, and X.  I am also using kernel-2.6.5-1.332.  The Call Trace
looks like thus:

Apr 29 04:04:20 dad kernel: fetchmail: page allocation failure.
order:1, mode:0x20
Apr 29 04:04:20 dad kernel: Call Trace:
Apr 29 04:04:20 dad kernel:  [<0213fbd3>] __alloc_pages+0x277/0x284
Apr 29 04:04:20 dad kernel:  [<0213fbf8>] __get_free_pages+0x18/0x24
Apr 29 04:04:20 dad kernel:  [<02143be5>] cache_grow+0x16b/0x3e0
Apr 29 04:04:20 dad kernel:  [<0229f6ae>] ip_route_output_flow+0x13/0x37
Apr 29 04:04:20 dad kernel:  [<0214420f>] cache_alloc_refill+0x3b5/0x3f1
Apr 29 04:04:20 dad kernel:  [<021446b5>] kmem_cache_alloc+0x56/0x143
Apr 29 04:04:20 dad kernel:  [<02283e2d>] sk_alloc+0x25/0x109
Apr 29 04:04:20 dad kernel:  [<022a5639>] ip_finish_output2+0x0/0x15f
Apr 29 04:04:20 dad kernel:  [<022bb914>]
tcp_create_openreq_child+0x27/0x62b
Apr 29 04:04:20 dad kernel:  [<022b8089>] tcp_v4_syn_recv_sock+0x53/0x33c
Apr 29 04:04:20 dad kernel:  [<022bc0ee>] tcp_check_req+0x1d6/0x30b
Apr 29 04:04:20 dad kernel:  [<021bc8bd>]
selinux_ip_postroute_last+0x20b/0x21d
Apr 29 04:04:20 dad kernel:  [<02295028>] qdisc_restart+0x10/0x3ce
Apr 29 04:04:20 dad kernel:  [<02288a20>] dev_queue_xmit+0x1f8/0x55d
Apr 29 04:04:20 dad kernel:  [<022a574b>] ip_finish_output2+0x112/0x15f
Apr 29 04:04:20 dad kernel:  [<02291652>] nf_hook_slow+0xc9/0x101
Apr 29 04:04:20 dad kernel:  [<022a375f>] ip_finish_output+0x194/0x19c
Apr 29 04:04:20 dad kernel:  [<022a5639>] ip_finish_output2+0x0/0x15f
Apr 29 04:04:20 dad kernel:  [<022a5628>] dst_output+0xb/0x1c
Apr 29 04:04:20 dad kernel:  [<02291652>] nf_hook_slow+0xc9/0x101
Apr 29 04:04:20 dad kernel:  [<021b789b>] avc_has_perm_noaudit+0x10b/0x488
Apr 29 04:04:20 dad kernel:  [<021bbc92>] selinux_parse_skb_ipv4+0x8d/0xe8
Apr 29 04:04:20 dad kernel:  [<021b7c57>] avc_has_perm+0x3f/0x49
Apr 29 04:04:20 dad kernel:  [<021bc603>]
selinux_socket_sock_rcv_skb+0x20e/0x21d
Apr 29 04:04:20 dad kernel:  [<022b83bf>] tcp_v4_hnd_req+0x4d/0x219
Apr 29 04:04:20 dad kernel:  [<022b8712>] tcp_v4_do_rcv+0x72/0xd0
Apr 29 04:04:20 dad kernel:  [<022b8c42>] tcp_v4_rcv+0x4d2/0x7c8
Apr 29 04:04:20 dad kernel:  [<2303a017>] ipt_hook+0x17/0x1c
[iptable_filter]
Apr 29 04:04:20 dad kernel:  [<022a11cc>]
ip_local_deliver_finish+0xc5/0x148
Apr 29 04:04:20 dad kernel:  [<02291652>] nf_hook_slow+0xc9/0x101
Apr 29 04:04:20 dad kernel:  [<022a0d63>] ip_local_deliver+0x197/0x19e
Apr 29 04:04:20 dad kernel:  [<022a1107>]
ip_local_deliver_finish+0x0/0x148
Apr 29 04:04:20 dad kernel:  [<022a1085>] ip_rcv+0x31b/0x39d
Apr 29 04:04:20 dad kernel:  [<02289221>] netif_receive_skb+0x14e/0x17b
Apr 29 04:04:20 dad kernel:  [<022892ba>] process_backlog+0x6c/0xd9
Apr 29 04:04:20 dad kernel:  [<02289384>] net_rx_action+0x5d/0xcd
Apr 29 04:04:20 dad kernel:  [<02122a69>] __do_softirq+0x35/0x73
Apr 29 04:04:20 dad kernel:  [<02108e74>] do_softirq+0x46/0x4d
Apr 29 04:04:20 dad kernel:  =======================
Apr 29 04:04:20 dad kernel:  [<022c509c>] inet_wait_for_connect+0x6c/0xc9
Apr 29 04:04:20 dad kernel:  [<0211bc6f>]
autoremove_wake_function+0x0/0x28
Apr 29 04:04:20 dad kernel:  [<0211bc6f>]
autoremove_wake_function+0x0/0x28
Apr 29 04:04:20 dad kernel:  [<022c51cc>] inet_stream_connect+0xd3/0x152
Apr 29 04:04:20 dad kernel:  [<02282865>] sys_connect+0x6b/0x86
Apr 29 04:04:20 dad kernel:  [<02178d9f>] d_instantiate+0x144/0x147
Apr 29 04:04:20 dad kernel:  [<02281708>] sock_map_file+0x98/0x106
Apr 29 04:04:20 dad kernel:  [<0214b563>] follow_page+0xe1/0xec
Apr 29 04:04:20 dad kernel:  [<0215b1f5>] rw_vm+0x399/0x425
Apr 29 04:04:20 dad kernel:  [<022830ca>] sys_socketcall+0x71/0x179
Apr 29 04:04:20 dad kernel:  [<0214f748>] sys_munmap+0x41/0x58
Apr 29 04:04:20 dad kernel:
Comment 3 Arjan van de Ven 2004-04-29 05:41:05 EDT
Thomas: yours is from ip_route_output_flow not dst_output though..
Comment 4 Thomas Molina 2004-04-29 06:00:43 EDT
So should I open a new entry, or just watch this one?
Comment 5 Tom London 2004-04-29 12:18:15 EDT
Created attachment 99793 [details]
kernel freezes with page allocation errors
Comment 6 Arjan van de Ven 2004-05-03 06:12:07 EDT
does kernel 349 on http://people.redhat.com/arjanv/2.6 behave better ?
(it has a somewhat tweaked VM)
Comment 7 Dave Jones 2004-06-14 20:45:35 EDT
numerous vm improvements lead me to think this is probably fixed.
reopen if otherwise.

Note You need to log in before you can comment on or make changes to this bug.