Bug 121711 - php-ldap incorrectly compiled; missing ldap_start_tls()
php-ldap incorrectly compiled; missing ldap_start_tls()
Status: CLOSED DUPLICATE of bug 119425
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: php (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-26 12:24 EDT by Richard L. Goerwitz III
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard L. Goerwitz III 2004-04-26 12:24:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040124

Description of problem:
The problem is that ldap_start_tls() is not compiled into the php-ldap
module.  This function is missing from RedHat's build. It is present
in RedHat 9, and it clearly should be present in RHEL AS 3.0 as well,
but it is not. 
 
We would simply have build the PHP modules ourselves, except that
unixODBC-devel is a prerequisite for building PHP (and we do use
unixODBC here).  Unfortunately, RedHat has not made the SRPM for
unixODBC available, which is unfortunate.

Reproducing the prolem is trivial; you don't need to write a PHP
script.  Just go to a command prompt and type: 
 
  php 
 
Then enter 
 
  <?php ldap_start_tls() ?> 
 
Under RedHat 9 (which has a correctly compiled php-ldap module) you'll
see an error explaining that you've called the above function with an
incorrect number of arguments. Under AS 3.0 you'll get a message that
the function doesn't exist. 
 
The reason it doesn't exist is explained earlier in this thread.  It
doesn't exist because the php-ldap module is not compiled correctly,
and we can't compile this module ourselves because the PHP SRPM
depends on unixODBC (the 'devel' package - which we use), which itself
is not available as an SRPM for RHEL AS 3.0.  And we can't seem to
download the 'devel' unixODBC package from RedHat.  It's not available. 
 
You could think of this as two bugs, actually:  1) That php-ldap is
wrongly compiled for AS 3.0, and 2) that we can't compile PHP
ourselves because it uses an important package unixODBC-devel which
isn't available, and which we can't build because a SRPM is not available.

Version-Release number of selected component (if applicable):
php-ldap-4.3.2-8.ent

How reproducible:
Always

Steps to Reproduce:
Reproducing the prolem is trivial; you don't need to write a PHP
script.  Just go to a command prompt and type: 
 
  php 
 
Then enter 
 
  <?php ldap_start_tls() ?> 
 
Under RedHat 9 (which has a correctly compiled php-ldap module) you'll
see an error explaining that you've called the above function with an
incorrect number of arguments. Under AS 3.0 you'll get a message that
the function doesn't exist. 
 
The reason it doesn't exist is explained earlier in this thread.  It
doesn't exist because the php-ldap module is not compiled correctly,
and we can't compile this module ourselves because the PHP SRPM
depends on unixODBC (the 'devel' package - which we use), which itself
is not available as an SRPM for RHEL AS 3.0.  And we can't seem to
download the 'devel' unixODBC package from RedHat.  It's not available. 
 
You could think of this as two bugs, actually:  1) That php-ldap is
wrongly compiled for AS 3.0, and 2) that we can't compile PHP
ourselves because it uses an important package unixODBC-devel which
isn't available, and which we can't build because a SRPM is not available.

Actual Results:  Error message

Expected Results:  Message that an incorrect number of arguments was
supplied to a function

Additional info:
Comment 1 Joe Orton 2004-04-28 14:11:34 EDT
Thanks for the report.  Test packages for the ldap_start_tls issue are
available from http://people.redhat.com/jorton/Taroon-php/ and also
the RHEL3 U2 beta channel on RHN.  The unixODBC-devel package is also
due to be included in RHEL3 U2.

*** This bug has been marked as a duplicate of 119425 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:02:46 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.