Bug 121725 - Test3 install has both XF86Config and xorg.conf with diff contents
Test3 install has both XF86Config and xorg.conf with diff contents
Status: CLOSED DUPLICATE of bug 121729
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-26 15:27 EDT by Dax Kelson
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dax Kelson 2004-04-26 15:27:46 EDT
Description of problem:

I just did a Test3 install. During firstboot --> display I changed my
color depth to "millions" instead of "thousands".

I noticed that I had both files:

/etc/X11/XF86Config
and
/etc/X11/xorg.conf

I don't know if that is intentional or not, but it's confusing at least.

The contents did differ:

--- /etc/X11/XF86Config 2004-04-26 09:23:09.000000000 -0600
+++ /etc/X11/xorg.conf  2004-04-26 02:00:59.000000000 -0600
@@ -1,4 +1,3 @@
-
 # XFree86 4 configuration created by pyxf86config
  
 Section "ServerLayout"
@@ -9,13 +8,14 @@
 EndSection
  
 Section "Files"
-
 # RgbPath is the location of the RGB database.  Note, this is the
name of the
 # file minus the extension (like ".txt" or ".db").  There is normally
 # no need to change the default.
+
 # Multiple FontPath entries are allowed (they are concatenated together)
 # By default, Red Hat 6.0 and later now use a font server independent of
 # the X server to render fonts.
+
        RgbPath      "/usr/X11R6/lib/X11/rgb"
        FontPath     "unix/:7100"
 EndSection
@@ -32,11 +32,12 @@
 EndSection
  
 Section "InputDevice"
-
 # Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
 #      Option  "Xleds"         "1 2 3"
+
 # To disable the XKEYBOARD extension, uncomment XkbDisable.
 #      Option  "XkbDisable"
+
 # To customise the XKB settings to suit your keyboard, modify the
 # lines below (which are the defaults).  For example, for a non-U.S.
 # keyboard, you will probably want to use:
@@ -73,14 +74,12 @@
 EndSection
  
 Section "Monitor"
-
- ### Uncomment if you don't want to default to DDC:
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "LCD Panel 1400x1050"
  ### Uncomment if you don't want to default to DDC:
-#      HorizSync    31.5 - 90.0
-#      VertRefresh  59.0 - 75.0
+       HorizSync    31.5 - 90.0
+       VertRefresh  59.0 - 75.0
        Option      "dpms"
 EndSection
                                                                     
                                                                     
                                                   
@@ -95,17 +94,12 @@
        Identifier "Screen0"
        Device     "Videocard0"
        Monitor    "Monitor0"
-       DefaultDepth     24
+       DefaultDepth     16
        SubSection "Display"
                Viewport   0 0
                Depth     16
                Modes    "1400x1050" "1280x1024" "1280x960" "1152x864"
"1024x768" "800x600" "640x480"
        EndSubSection
-       SubSection "Display"
-               Viewport   0 0
-               Depth     24
-               Modes    "1400x1050" "1280x1024" "1280x960" "1152x864"
"1024x768" "800x600" "640x480"
-       EndSubSection
 EndSection
                                                                     
                                                                     
                                                   
 Section "DRI"
Comment 1 Dax Kelson 2004-04-26 15:31:02 EDT
BTW, according to SELinux rhgb is trying to read /etc/X11/XF86Config.
I filed that as bug 121726.
Comment 2 Phil Schaffner 2004-04-27 09:03:09 EDT
Did a fresh NFS install of rawhide/fc2t3: server + KDE/Gnome +
development + graphical internet + multimedia + some additional tools.
The configuration specified in the firstboot setup was written to
/etc/X11/XF86Config, but X started with the default values in
/etc/X11/xorg.conf.  Copying /etc/X11/XF86Config over
/etc/X11/xorg.conf gives the desired behavior.  Attempting to
reconfigure X from the Gnome "System Settings/Display" menu as root
only gives resolution options of 640x480 or 800x600.  (This is
probably another bug - will file as such.)
Comment 3 Dax Kelson 2004-04-27 12:29:29 EDT

*** This bug has been marked as a duplicate of 121729 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:02:47 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.