Bug 121729 - FC2 test3 -- setting display properties within firstboot updates/creates /etc/X11/XF86Config
FC2 test3 -- setting display properties within firstboot updates/creates /etc...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
: 121725 121863 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-26 15:40 EDT by Dax Kelson
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-30 15:32:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dax Kelson 2004-04-26 15:40:26 EDT
Description of problem:

I just installed current rawhide which I believe is the same as FC2 test3.

In firstboot, I changed my display properties from "thousands" to
"millions" of colors.

It appears as if that created (or possibly modified) the file
/etc/X11/XF86Config since I now have two files /etc/X11/XF86Config and
/etc/X11/xorg.conf and the XF86Config has the 'millions' of colors
setting.

--- /etc/X11/XF86Config 2004-04-26 09:23:09.000000000 -0600
+++ /etc/X11/xorg.conf  2004-04-26 02:00:59.000000000 -0600
@@ -1,4 +1,3 @@
-
 # XFree86 4 configuration created by pyxf86config
  
 Section "ServerLayout"
@@ -9,13 +8,14 @@
 EndSection
  
 Section "Files"
-
 # RgbPath is the location of the RGB database.  Note, this is the
name of the
 # file minus the extension (like ".txt" or ".db").  There is normally
 # no need to change the default.
+
 # Multiple FontPath entries are allowed (they are concatenated together)
 # By default, Red Hat 6.0 and later now use a font server independent of
 # the X server to render fonts.
+
        RgbPath      "/usr/X11R6/lib/X11/rgb"
        FontPath     "unix/:7100"
 EndSection
@@ -32,11 +32,12 @@
 EndSection
  
 Section "InputDevice"
-
 # Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
 #      Option  "Xleds"         "1 2 3"
+
 # To disable the XKEYBOARD extension, uncomment XkbDisable.
 #      Option  "XkbDisable"
+
 # To customise the XKB settings to suit your keyboard, modify the
 # lines below (which are the defaults).  For example, for a non-U.S.
 # keyboard, you will probably want to use:
@@ -73,14 +74,12 @@
 EndSection
  
 Section "Monitor"
-
- ### Uncomment if you don't want to default to DDC:
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "LCD Panel 1400x1050"
  ### Uncomment if you don't want to default to DDC:
-#      HorizSync    31.5 - 90.0
-#      VertRefresh  59.0 - 75.0
+       HorizSync    31.5 - 90.0
+       VertRefresh  59.0 - 75.0
        Option      "dpms"
 EndSection
  
@@ -95,17 +94,12 @@
        Identifier "Screen0"
        Device     "Videocard0"
        Monitor    "Monitor0"
-       DefaultDepth     24
+       DefaultDepth     16
        SubSection "Display"
                Viewport   0 0
                Depth     16
                Modes    "1400x1050" "1280x1024" "1280x960" "1152x864"
"1024x768" "800x600" "640x480"
        EndSubSection
-       SubSection "Display"
-               Viewport   0 0
-               Depth     24
-               Modes    "1400x1050" "1280x1024" "1280x960" "1152x864"
"1024x768" "800x600" "640x480"
-       EndSubSection
 EndSection
  
 Section "DRI"
Comment 1 Phil Schaffner 2004-04-27 09:30:23 EDT
This appears to be a duplicate of 121725.  The X setup run from
firstboot creates /etc/X11/XF86Config but X starts with the default
values in /etc/X11/xorg.conf.  Copying /etc/X11//XF86Config over
/etc/X11/xorg.conf gives the behavior specified by the user during
firstboot setup.  The firstboot X setup should write to
/etc/X11/xorg.conf and there is no apparent reason to have
etc/X11/XF86Config.
Comment 2 Dax Kelson 2004-04-27 12:29:25 EDT
Agreed (it was tired when I was filing these bugs). But this bug is
against the offending component.
Comment 3 Dax Kelson 2004-04-27 12:29:31 EDT
*** Bug 121725 has been marked as a duplicate of this bug. ***
Comment 4 Brent Fox 2004-04-30 15:32:22 EDT
Should be fixed in system-config-display-1.0.14-1 in Rawhide.
Comment 5 Brent Fox 2004-05-03 10:47:30 EDT
*** Bug 121863 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.