Bug 121743 - G++ says: internal compiler error: in cp_expr_size, at cp/cp-lang.c:312
G++ says: internal compiler error: in cp_expr_size, at cp/cp-lang.c:312
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-27 03:15 EDT by Mattias Ellert
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-25 11:35:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A short test program that triggers the bug (2.19 KB, text/plain)
2004-04-27 03:16 EDT, Mattias Ellert
no flags Details

  None (edit)
Description Mattias Ellert 2004-04-27 03:15:19 EDT
Description of problem:
When I try to compile the file in the attachment on a machine running
Fedora Core 1 and gcc 3.3.2 I get:

[ellert@localhost tmp]$ g++ -o gcc332bug gcc332bug.cpp
gcc332bug.cpp: In function `int main()':
gcc332bug.cpp:94: internal compiler error: in cp_expr_size, at
cp/cp-lang.c:312
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /tmp/ccGqmoZQ.out file, please attach
this to your bugreport

If I use the workaround implemented with #ifdef BROKEN_GCC it does not
complain:

[ellert@localhost tmp]$ g++ -o gcc332bug -DBROKEN_GCC gcc332bug.cpp

If I compile it on a machine running RedHat 9 with gcc 3.2.2 instead
it works, so this bug was introduced somewhere between version 3.2.2
and 3.3.2.


Version-Release number of selected component (if applicable):
gcc-c++-3.3.2-1

How reproducible:
Always

Steps to Reproduce:
1. Compile the attached file with g++ 3.3.2
    

Actual Results:  Compiler error

Expected Results:  No error

Additional info:
Comment 1 Mattias Ellert 2004-04-27 03:16:34 EDT
Created attachment 99710 [details]
A short test program that triggers the bug
Comment 2 Jakub Jelinek 2004-05-25 11:35:14 EDT
Works for me in gcc-c++-3.3.2-6 (updates/1/testing/) and
gcc-c++-3.3.3-7 (FC2).

Note You need to log in before you can comment on or make changes to this bug.