Bug 121776 - redhat-config-printer allows two queues with the same name
redhat-config-printer allows two queues with the same name
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-printer (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-27 14:19 EDT by Steve Bonneville
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:27:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Sample /etc/cups/printers.conf file. (504 bytes, text/plain)
2004-04-28 15:25 EDT, Steve Bonneville
no flags Details

  None (edit)
Description Steve Bonneville 2004-04-27 14:19:10 EDT
Description of problem:

CUPS printer queue names are case-insensitive. The wizard to "Add a
new print queue" in redhat-config-printer allows two queues to be
created which have the same name, if they are capitalized differently.
Jobs printed to one queue seem to show up in both, but I don't have a
pair of test printers available to see if the print job will show up
on both printers, neither, or if CUPS explodes.

See also related bug #121772.

Version-Release number of selected component (if applicable):
redhat-config-printer-0.6.47.3.13-1
cups-1.1.17-13.3.6

How reproducible:
With redhat-config-printer, add a printer named "local" and a printer
with a different configuration named "LOCAL".  Send a print job to
local, and view the queues for both printers.
Comment 1 Steve Bonneville 2004-04-28 15:25:54 EDT
Created attachment 99752 [details]
Sample /etc/cups/printers.conf file.
Comment 2 Steve Bonneville 2004-04-28 15:29:20 EDT
I realized after posting this that the job shows up in "both queues"
because lpq can't distinguish between -P local and -P LOCAL.  However,
as seen in the attachment above, redhat-config-printer still tries to
set up two queues in /etc/cups/printers.conf, and I'm still not sure
which, if either, printer the print job would show up on.
Comment 3 Tim Waugh 2004-04-30 09:05:23 EDT
Yes, it ought to disallow that.
Comment 4 RHEL Product and Program Management 2007-10-19 15:27:10 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.