Bug 121849 - kbuild external modules requires writable kernel source
kbuild external modules requires writable kernel source
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
All Linux
low Severity low
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-28 13:07 EDT by Gerald Britton
Modified: 2015-01-04 17:05 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-07 11:14:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerald Britton 2004-04-28 13:07:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;)
Gecko/20020623 Debian/1.2.5-0.woody.1

Description of problem:
The kernel sources provided in /lib/modules/*/build work well to
build external modules, however, they try to write ./.__modpost.cmd
into the top level kernel directory while building, which fails when
building modules as a non-root user.

Version-Release number of selected component (if applicable):
kernel-2.6.5-1.327

How reproducible:
Always

Steps to Reproduce:
1. obtain an external module source
2. be not root
3. make -C /lib/modules/VER/build SUBDIRS=/path/to/mod modules


Actual Results:  module build fails

Expected Results:  module build succeeds

Additional info:
Comment 1 Arjan van de Ven 2004-04-28 13:09:34 EDT
you need to be root to load them anyway so for sure not a super big deal.
Comment 2 Gary Lerhaupt 2004-05-03 17:36:23 EDT
Please include this patch:

http://linus.bkbits.net:8080/linux-
2.5/cset@408dfac2C9_AR5WZykNWVUG0CPhzfw?nav=index.html|ChangeSet@-7d

to fix external module building for 2.6.  This is needed in both FC2 
and RHEL4.  Upping the severity as this is a Dell concern for DKMS to 
function on these kernels.
Comment 3 Arjan van de Ven 2004-05-03 17:39:17 EDT
dropping the severity because I really don't care much. You need to be
root to insmod a kernel module after all, being root somewhat sooner
isn't a big deal.
Comment 4 Gary Lerhaupt 2004-05-03 18:02:39 EDT
aha, I misread the bug.  In general, the external module building is 
broken in FC2-T3.  Specifically, the FC2T3 kernel itself works okay 
to build modules externally.  But, if you recompile the kernel, 
the /lib/modules/$kernelver/build directory changes back to the old 
symlink style to /usr/src and thereafter, external module building is 
broken.  Would you prefer that I open a separate bugzilla?
Comment 5 Arjan van de Ven 2004-05-04 03:45:58 EDT
recompiling is unsupported in that if things break you get to hold two
pieces...
Comment 6 Dave Jones 2004-12-07 01:43:51 EST
fixed in 2.6.9 based update ?
Comment 7 Gerald Britton 2004-12-07 08:54:05 EST
I removed my workaround from my module rpm's spec file and it successfully built
under a non-root user, so it does seem to be fixed using kernel-2.6.9-1.6_FC2.

Note You need to log in before you can comment on or make changes to this bug.