Bug 12189 - ypbind fails on boot
ypbind fails on boot
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: ypbind (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Florian La Roche
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-13 06:46 EDT by Matteo Panella
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-13 15:29:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matteo Panella 2000-06-13 06:46:00 EDT
When I try to run ypbind on a diskless workstation (root on the NIS server
mounted via NFS, eth0 configured via RARP, a 16M swapfile on a vfat
partition, 24Megs of RAM, i586 CPU at 100MHz) with the -ipc option (the man
page says it is necessary on a NFS-root filesystem) on tty1 appears
"neigbour table overflow" two times, then the script says it can't talk
with ypbind.
I tried to run ypbind manually with -ipc and -debug options and this is the
output:
neighbour table overflow
neighbour table overflow
Cannot register service: RPC: Unable to send; errno = No buffer space
available
unable to register (YPBINDPROG, YPBINDVERS, udp)
:No buffer space available
Comment 1 Matteo Panella 2000-06-13 15:29:50 EDT
It seems that this is an RPC-specific problem because I get the same error when
I try to run an application that uses RPC.
Comment 2 Florian La Roche 2000-07-14 04:55:21 EDT
shouldn't be a problem with ypbind. the kernel messages are harmless. the
machine seems to
have to memory available.

if this is still a problem, reopen this bug with more information.

Note You need to log in before you can comment on or make changes to this bug.