Bug 121896 - Hard system crash on bluetooth USB dongle removal
Summary: Hard system crash on bluetooth USB dongle removal
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Pete Zaitcev
QA Contact:
URL:
Whiteboard:
Keywords:
: 118783 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-28 22:09 UTC by Bob Gustafson
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-26 04:40:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Oops in hci_usb at device removal (10.76 KB, text/plain)
2004-05-04 16:47 UTC, Antti Andreimann
no flags Details

Description Bob Gustafson 2004-04-28 22:09:09 UTC
Description of problem:

  When I pull the bluetooth dongle (D-Link DBT-120) from the USB hole,
my system crashes. The mouse freezes, I cannot ping or telnet to box
from another networked box. Power cycle brings it back.

Version-Release number of selected component (if applicable):

  It is probably somewhere in the hotplug USB bluetooth maze. All
components are from FC2-test3

How reproducible:
  Always

Steps to Reproduce:
1. plug in dongle
2. unplug dongle
3.
  
Actual results:
 When the dongle is plugged in, its power light is lit and some
stats/properties of the dongle show up in the
 'System Tools -> Info Center -> USB devices'
display.

Expected results:
 No crash, Info Center stats/properties go away.

Additional info:
  This has been reported before (months ago).

Comment 1 Antti Andreimann 2004-05-04 16:46:33 UTC
The problem seems to be quite common. 
I have ThinkPad T41 laptop with exactly the same symptoms. 
dmesg from Oops test in single user mode is included. 

Comment 2 Antti Andreimann 2004-05-04 16:47:44 UTC
Created attachment 99960 [details]
Oops in hci_usb at device removal

Comment 3 Antti Andreimann 2004-05-04 17:13:12 UTC
Kernel buzilla entry for this bug: 
http://bugme.osdl.org/show_bug.cgi?id=2423 

Comment 4 Bob Gustafson 2004-05-08 22:37:59 UTC
*** Bug 118783 has been marked as a duplicate of this bug. ***

Comment 5 Bob Gustafson 2004-05-26 04:40:32 UTC
I have done a clean install of FC2 and have tested the Bluetooth
dongle insertion and removal works fine - no crash.

Now need to test whether the Bluetooth itself works, but that is
another bug report - if needed.

Works for me..


Note You need to log in before you can comment on or make changes to this bug.