Bug 1219 - Syntax error in /etc/rc.d/init.d/single
Summary: Syntax error in /etc/rc.d/init.d/single
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 5.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL: ftp://updates.redhat.com/5.2/kernel-2...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-02-17 15:55 UTC by dim
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-02-17 16:01:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description dim 1999-02-17 15:55:01 UTC
Due to a missing `fi' in /etc/rc.d/init.d/single, you get a
syntax error from bash while switching to single user mode,
and you get no shell.
This happens only with the new initscripts package which has
been made for kernel 2.2 support.

--- single.orig Wed Feb 10 18:46:58 1999
+++ single      Wed Feb 17 16:04:59 1999
@@ -33,6 +33,7 @@
    echo "/sbin/modprobe" > /proc/sys/kernel/modprobe
 else
    /etc/rc.d/init.d/kerneld start
+fi

 # Now go to the single user level.
 echo "Telling INIT to go to single user mode."

Comment 1 Bill Nottingham 1999-02-17 16:01:59 UTC
fixed in initscripts-3.78-2.3


Note You need to log in before you can comment on or make changes to this bug.